cPropMaterialGetNameList Method

Retrieves the names of all defined material properties of the specified type.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetNameList(
	ref int NumberNames,
	ref string[] MyName,
	eMatType MatType = 
)

Parameters

NumberNames
Type: SystemInt32
The number of material property names retrieved by the program.
MyName
Type: SystemString
One-dimensional array of material property names. The MyName array is created as a dynamic, zero-based, array by the API user:

Dim MyName() as String

The array is dimensioned to (NumberNames - 1) inside the program, filled with the names, and returned to the API user.
MatType (Optional)
Type: ETABS2016eMatType
This optional value is one of the items in the eMatType enumeration.

If no value is input for MatType, names are returned for all material properties in the model regardless of type.

Return Value

Type: Int32
Returns zero if the names are successfully retrieved; otherwise it returns nonzero.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim NumberNames As Integer
       Dim MyName() As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'get material property names
       ret = SapModel.PropMaterial.GetNameList(NumberNames, MyName)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also