cPropRebarGetNameList Method |
Retrieves the names of all defined rebar properties
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetNameList(
ref int NumberNames,
ref string[] MyName
)
Function GetNameList (
ByRef NumberNames As Integer,
ByRef MyName As String()
) As Integer
int GetNameList(
int% NumberNames,
array<String^>^% MyName
)
abstract GetNameList :
NumberNames : int byref *
MyName : string[] byref -> int
Parameters
- NumberNames
- Type: SystemInt32
The number of rebar properties
- MyName
- Type: SystemString
This is a one-dimensional array of rebar property names. The MyName array is created
as a dynamic, zero-based, array by the API user:
Dim MyName() as String
The array is dimensioned to (NumberNames – 1)
inside the ETABS program, filled with the names, and returned to the API user.
Return Value
Type:
Int32
Returns zero if the data is successfully retrieved, otherwise it returns nonzero
Remarks
See Also