cViewRefreshView Method

Refreshes the view for the specified window(s).

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int RefreshView(
	int Window = 0,
	bool Zoom = true
)

Parameters

Window (Optional)
Type: SystemInt32
This is 0 meaning all windows or an existing window number. It indicates the window(s) to have its view refreshed.
Zoom (Optional)
Type: SystemBoolean
If this item is True, the window zoom is maintained when the view is refreshed. If it is False, the zoom returns to a default zoom.

Return Value

Type: Int32
Returns zero if the window views are successfully refreshed; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'refresh view
       ret = SapModel.View.RefreshView()

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also