cDesignSteelSetCode Method

Sets the steel design code.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetCode(
	string CodeName
)

Parameters

CodeName
Type: SystemString
This is one of the following steel design code names.
  • AISC 360-10/IBC 2012
  • AISC 360-05/IBC 2006
  • AISC ASD 01
  • AISC ASD 89
  • AISC LRFD 99
  • AISC LRFD 93
  • AS 4100-1998
  • BS 5950-2000
  • BS 5950-1990
  • CAN/CSA S16-01
  • Chinese 2010
  • CISC 95
  • CSA S16-09
  • Eurocode 3-2005
  • Eurocode 3-1993
  • Indian IS:800-2007
  • Indian IS:800-1998
  • Italian UNI 10011
  • NZS 3404-1997
  • UBC ASD 97
  • UBC LRFD 97

Return Value

Type: Int32
Returns zero if the code is successfully set; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1
   Dim CodeName As String

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
   ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'set steel design code
   ret = SapModel.DesignSteel.SetCode("Eurocode 3-2005")

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also