cPropTendonSetProp Method |
Defines a tendon property
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetProp(
string Name,
string MatProp,
int ModelingOption,
double Area,
int Color = -1,
string Notes = "",
string GUID = ""
)
Function SetProp (
Name As String,
MatProp As String,
ModelingOption As Integer,
Area As Double,
Optional Color As Integer = -1,
Optional Notes As String = "",
Optional GUID As String = ""
) As Integer
int SetProp(
String^ Name,
String^ MatProp,
int ModelingOption,
double Area,
int Color = -1,
String^ Notes = L"",
String^ GUID = L""
)
abstract SetProp :
Name : string *
MatProp : string *
ModelingOption : int *
Area : float *
?Color : int *
?Notes : string *
?GUID : string
(* Defaults:
let _Color = defaultArg Color -1
let _Notes = defaultArg Notes ""
let _GUID = defaultArg GUID ""
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing or new tendon property.
If this is an existing property, that property is modified; otherwise, a new property is added. - MatProp
- Type: SystemString
The name of the material property assigned to the tendon property. - ModelingOption
- Type: SystemInt32
This is either 1 or 2, indicating the tendon modeling option.
Value | Modeling Option |
---|
1 | Model tendon as loads |
2 | Model tendon as elements |
- Area
- Type: SystemDouble
The cross-sectional area of the tendon. [L2] - Color (Optional)
- Type: SystemInt32
- Notes (Optional)
- Type: SystemString
- GUID (Optional)
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the property.
If this item is input as Default, the program assigns a GUID to the property
Return Value
Type:
Int32Returns zero if the property is successfully defined; otherwise it returns a nonzero value.
RemarksModeling tendons as elements (
ModelingOption = 2) is not supported in ETABS.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropMaterial.AddQuick(Name, eMatType.Tendon, , , , , , eMatTypeTendon.ASTM_A416Gr270)
ret = SapModel.PropTendon.SetProp("T1", Name, 1, 2.25)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also