cDesignConcreteGetDesignSection Method

Retrieves the design section for a specified concrete frame object

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetDesignSection(
	string Name,
	ref string PropName
)

Parameters

Name
Type: SystemString
The name of a frame object with a concrete frame design procedure
PropName
Type: SystemString
The name of the design section for the specified frame object

Return Value

Type: Int32
Returns zero if the section is successfully retrieved; otherwise it returns a nonzero value
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

ret = SapModel.File.NewGridOnly(1, 10, 10, 2, 2, 10, 10)

'create new concrete frame section properties
  ret = SapModel.PropFrame.SetRectangle("R1", "4000Psi", 20, 12)
  ret = SapModel.PropFrame.SetRectangle("R2", "4000Psi", 20, 16)

'create a concrete column
Dim FrameName1 As String
ret = SapModel.FrameObj.AddByCoord(0, 0, 0, 0, 0, 10, FrameName1, "R1")

'run analysis
  ret = SapModel.File.Save("C:\ETABSAPI\example.edb")
  ret = SapModel.Analyze.RunAnalysis

'start concrete design
  ret = SapModel.DesignConcrete.StartDesign

'get design section
Dim PropName As String
ret = SapModel.DesignConcrete.GetDesignSection(FrameName1, PropName)

'set design section
  ret = SapModel.DesignConcrete.SetDesignSection(FrameName1, "R2", False)

ret = SapModel.DesignConcrete.GetDesignSection(FrameName1, PropName)

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also