cAreaObjGetDiaphragm Method

Retrieves the diaphragm assignment to the specified area object

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetDiaphragm(
	string Name,
	ref string DiaphragmName
)

Parameters

Name
Type: SystemString
The name of a defined area object.
DiaphragmName
Type: SystemString
The name of the diaphragm assigned to the area object. This item is "None" if no diaphragm is assigned to the area object.

Return Value

Type: Int32
Returns zero if the diaphragm is successfully retrieved; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1
   Dim DiaphragmName As String

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
   ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'define a new diaphragm
    ret = SapModel.Diaphragm.SetDiaphragm("MyDiaph1A", SemiRigid:=True)

'assign diaphragm to area
    ret = SapModel.AreaObj.SetDiaphragm("4", "MyDiaph1A")

'get area diaphragm assignment
    ret = SapModel.AreaObj.GetDiaphragm("4", DiaphragmName)

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also