cDesignSteelGetSummaryResults_2 Method |
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetSummaryResults_2(
string Name,
ref int NumberItems,
ref string[] FrameType,
ref string[] DesignSect,
ref string[] Status,
ref string[] PMMCombo,
ref double[] PMMRatio,
ref double[] PRatio,
ref double[] MMajRatio,
ref double[] MMinRatio,
ref string[] VMajCombo,
ref double[] VMajRatio,
ref string[] VMinCombo,
ref double[] VMinRatio,
eItemType ItemType = eItemType.Objects
)
Function GetSummaryResults_2 (
Name As String,
ByRef NumberItems As Integer,
ByRef FrameType As String(),
ByRef DesignSect As String(),
ByRef Status As String(),
ByRef PMMCombo As String(),
ByRef PMMRatio As Double(),
ByRef PRatio As Double(),
ByRef MMajRatio As Double(),
ByRef MMinRatio As Double(),
ByRef VMajCombo As String(),
ByRef VMajRatio As Double(),
ByRef VMinCombo As String(),
ByRef VMinRatio As Double(),
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int GetSummaryResults_2(
String^ Name,
int% NumberItems,
array<String^>^% FrameType,
array<String^>^% DesignSect,
array<String^>^% Status,
array<String^>^% PMMCombo,
array<double>^% PMMRatio,
array<double>^% PRatio,
array<double>^% MMajRatio,
array<double>^% MMinRatio,
array<String^>^% VMajCombo,
array<double>^% VMajRatio,
array<String^>^% VMinCombo,
array<double>^% VMinRatio,
eItemType ItemType = eItemType::Objects
)
abstract GetSummaryResults_2 :
Name : string *
NumberItems : int byref *
FrameType : string[] byref *
DesignSect : string[] byref *
Status : string[] byref *
PMMCombo : string[] byref *
PMMRatio : float[] byref *
PRatio : float[] byref *
MMajRatio : float[] byref *
MMinRatio : float[] byref *
VMajCombo : string[] byref *
VMajRatio : float[] byref *
VMinCombo : string[] byref *
VMinRatio : float[] byref *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
- NumberItems
- Type: SystemInt32
- FrameType
- Type: SystemString
- DesignSect
- Type: SystemString
- Status
- Type: SystemString
- PMMCombo
- Type: SystemString
- PMMRatio
- Type: SystemDouble
- PRatio
- Type: SystemDouble
- MMajRatio
- Type: SystemDouble
- MMinRatio
- Type: SystemDouble
- VMajCombo
- Type: SystemString
- VMajRatio
- Type: SystemDouble
- VMinCombo
- Type: SystemString
- VMinRatio
- Type: SystemDouble
- ItemType (Optional)
- Type: ETABS2016eItemType
Return Value
Type:
Int32
See Also