cPropLinkGetLinear Method |
Retrieves link property data for a linear-type link property.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetLinear(
string Name,
ref bool[] DOF,
ref bool[] Fixed,
ref double[] Ke,
ref double[] Ce,
ref double DJ2,
ref double DJ3,
ref bool KeCoupled,
ref bool CeCoupled,
ref string Notes,
ref string GUID
)
Function GetLinear (
Name As String,
ByRef DOF As Boolean(),
ByRef Fixed As Boolean(),
ByRef Ke As Double(),
ByRef Ce As Double(),
ByRef DJ2 As Double,
ByRef DJ3 As Double,
ByRef KeCoupled As Boolean,
ByRef CeCoupled As Boolean,
ByRef Notes As String,
ByRef GUID As String
) As Integer
int GetLinear(
String^ Name,
array<bool>^% DOF,
array<bool>^% Fixed,
array<double>^% Ke,
array<double>^% Ce,
double% DJ2,
double% DJ3,
bool% KeCoupled,
bool% CeCoupled,
String^% Notes,
String^% GUID
)
abstract GetLinear :
Name : string *
DOF : bool[] byref *
Fixed : bool[] byref *
Ke : float[] byref *
Ce : float[] byref *
DJ2 : float byref *
DJ3 : float byref *
KeCoupled : bool byref *
CeCoupled : bool byref *
Notes : string byref *
GUID : string byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing linear-type link property. - DOF
- Type: SystemBoolean
- Fixed
- Type: SystemBoolean
This is a boolean array, dimensioned to 5,
indicating if the specified degree of freedom is fixed (restrained).
Value | Fixity |
---|
Fixed(0) | U1 fixity if DOF(0) = True |
Fixed(1) | U2 fixity if DOF(1) = True |
Fixed(2) | U3 fixity if DOF(2) = True |
Fixed(3) | R1 fixity if DOF(3) = True |
Fixed(4) | R2 fixity if DOF(4) = True |
Fixed(5) | R3 fixity if DOF(5) = True |
- Ke
- Type: SystemDouble
- Ce
- Type: SystemDouble
- DJ2
- Type: SystemDouble
- DJ3
- Type: SystemDouble
- KeCoupled
- Type: SystemBoolean
This item is True if the link stiffness, Ke, is coupled.
There are 21 terms in the Ke array if Ke is coupled;
otherwise there are 6 terms - CeCoupled
- Type: SystemBoolean
This item is True if the link damping, Ce, is coupled.
There are 21 terms in the Ce array if Ce is coupled;
otherwise there are 6 terms - Notes
- Type: SystemString
- GUID
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the property.
Return Value
Type:
Int32Returns zero if the property data is successfully retrieved;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim MyDOF() As Boolean
Dim MyFixed() As Boolean
Dim MyKe() As Double
Dim MyCe() As Double
Dim DOF() As Boolean
Dim Fixed() As Boolean
Dim Ke() As Double
Dim Ce() As Double
Dim dj2 As Double
Dim dj3 As Double
Dim KeCoupled As Boolean
Dim CeCoupled As Boolean
Dim Notes As String
Dim GUID As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ReDim MyDOF(5)
ReDim MyFixed(5)
ReDim MyKe(5)
ReDim MyCe(5)
MyDOF(0) = True
MyKe(0) = 12
ret = SapModel.PropLink.SetLinear("L1", MyDOF, MyFixed, MyKe, MyCe, 0, 0)
ret = SapModel.PropLink.GetLinear("L1", DOF, Fixed, Ke, Ce, dj2, dj3, KeCoupled, CeCoupled, Notes, GUID)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also