cPropLinkGetDamperBilinear Method |
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetDamperBilinear(
string Name,
ref bool[] dof,
ref bool[] Fixed,
ref bool[] Nonlinear,
ref double[] ke,
ref double[] ce,
ref double[] k,
ref double[] c,
ref double[] CY,
ref double[] ForceLimit,
ref double dj2,
ref double dj3,
ref string notes,
ref string GUID
)
Function GetDamperBilinear (
Name As String,
ByRef dof As Boolean(),
ByRef Fixed As Boolean(),
ByRef Nonlinear As Boolean(),
ByRef ke As Double(),
ByRef ce As Double(),
ByRef k As Double(),
ByRef c As Double(),
ByRef CY As Double(),
ByRef ForceLimit As Double(),
ByRef dj2 As Double,
ByRef dj3 As Double,
ByRef notes As String,
ByRef GUID As String
) As Integer
int GetDamperBilinear(
String^ Name,
array<bool>^% dof,
array<bool>^% Fixed,
array<bool>^% Nonlinear,
array<double>^% ke,
array<double>^% ce,
array<double>^% k,
array<double>^% c,
array<double>^% CY,
array<double>^% ForceLimit,
double% dj2,
double% dj3,
String^% notes,
String^% GUID
)
abstract GetDamperBilinear :
Name : string *
dof : bool[] byref *
Fixed : bool[] byref *
Nonlinear : bool[] byref *
ke : float[] byref *
ce : float[] byref *
k : float[] byref *
c : float[] byref *
CY : float[] byref *
ForceLimit : float[] byref *
dj2 : float byref *
dj3 : float byref *
notes : string byref *
GUID : string byref -> int
Parameters
- Name
- Type: SystemString
- dof
- Type: SystemBoolean
- Fixed
- Type: SystemBoolean
- Nonlinear
- Type: SystemBoolean
- ke
- Type: SystemDouble
- ce
- Type: SystemDouble
- k
- Type: SystemDouble
- c
- Type: SystemDouble
- CY
- Type: SystemDouble
- ForceLimit
- Type: SystemDouble
- dj2
- Type: SystemDouble
- dj3
- Type: SystemDouble
- notes
- Type: SystemString
- GUID
- Type: SystemString
Return Value
Type:
Int32
See Also