cDStAISC360_05_IBC2006SetPreference Method |
Sets the value of a steel design preference item.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetPreference(
int Item,
double Value
)
Function SetPreference (
Item As Integer,
Value As Double
) As Integer
int SetPreference(
int Item,
double Value
)
abstract SetPreference :
Item : int *
Value : float -> int
Parameters
- Item
- Type: SystemInt32
This is an integer between 1 and 29, inclusive,
indicating the preference item considered.
- Framing type
- Seismic design category
- Design provision
- Analysis method (Obsolete, replaced by 27, 28, and 29)
- Notional load coefficient
- Phi bending
- Phi compression
- Phi tension yielding
- Phi tension fracture
- Phi shear
- Phi shear sort webbed rolled I
- Phi torsion
- Ignore seismic code
- Ignore special seismic load
- Doubler plate is plug welded
- HSS welding type
- Reduce HSS thickness
- Consider deflection
- DL deflection limit, L/Value
- SDL + LL deflection limit, L/Value
- LL deflection limit, L/Value
- Total load deflection limit, L/Value
- Total camber limit, L/Value
- Pattern live load factor
- Demand/capacity ratio limit
- Multi-response case design
- Analysis Method
- Second Order Method
- Stiffness Reduction Method
- Value
- Type: SystemDouble
The value of the considered preference item.
-
Framing type
- SMF
- IMF
- OMF
- SCBF
- OCBF
- OCBFI
- EBF
-
Seismic design category
- A
- B
- C
- D
- E
- F
-
Design provision
- LRFD
- ASD
-
Analysis method (Obsolete, replaced by 27, 28, and 29)
- Gen 2nd Order Elastic
- 2nd Order By Amp 1st Order
- Limited 1st Order Elastic
- DAM Gen 2nd Order Taub Variable
- DAM Gen 2nd Order Taub Fixed
- DAM Amp 1st Order Taub Variable
- DAM Amp 1st Order Taub Fixed
-
Notional load coefficient
Value > 0
-
Phi bending
Value > 0
-
Phi compression
Value > 0
-
Phi tension yielding
Value > 0
-
Phi tension fracture
Value > 0
-
Phi shear
Value > 0
-
Phi shear sort webbed rolled I
Value > 0
-
Phi torsion
Value > 0
-
Ignore seismic code
0 = No
Any other value = Yes
-
Ignore special seismic load
0 = No
Any other value = Yes
-
Doubler plate is plug welded
0 = No
Any other value = Yes
-
HSS welding type
- ERW
- SAW
-
Reduce HSS thickness
0 = No
Any other value = Yes
-
Consider deflection
0 = No
Any other value = Yes
-
DL deflection limit, L/Value
Value > 0
-
SDL + LL deflection limit, L/Value
Value > 0
-
LL deflection limit, L/Value
Value > 0
-
Total load deflection limit, L/Value
Value > 0
-
Total camber limit, L/Value
Value > 0
-
Pattern live load factor
Value > 0
-
Demand/capacity ratio limit
Value > 0
-
Multi-response case design
- Envelopes
- Step-by-step
- Last step
- Envelopes -- All
- Step-by-step -- All
-
Analysis Method
- Direct Analysis
- Effective Length
- Limited 1st Order
-
Second Order Method
- General 2nd Order
- Amplified 1st Order
-
Stiffness Reduction Method
- Tau-b variable
- Tau-b Fixed
- No Modification
Return Value
Type:
Int32
Returns zero if the item is successfully set;
otherwise it returns a nonzero value.
Remarks
See Also