cDesignConcreteGetSummaryResultsBeam Method |
Retrieves beam summary results for concrete design.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetSummaryResultsBeam(
string Name,
ref int NumberItems,
ref string[] FrameName,
ref double[] Location,
ref string[] TopCombo,
ref double[] TopArea,
ref string[] BotCombo,
ref double[] BotArea,
ref string[] VMajorCombo,
ref double[] VMajorArea,
ref string[] TLCombo,
ref double[] TLArea,
ref string[] TTCombo,
ref double[] TTArea,
ref string[] ErrorSummary,
ref string[] WarningSummary,
eItemType ItemType = eItemType.Objects
)
Function GetSummaryResultsBeam (
Name As String,
ByRef NumberItems As Integer,
ByRef FrameName As String(),
ByRef Location As Double(),
ByRef TopCombo As String(),
ByRef TopArea As Double(),
ByRef BotCombo As String(),
ByRef BotArea As Double(),
ByRef VMajorCombo As String(),
ByRef VMajorArea As Double(),
ByRef TLCombo As String(),
ByRef TLArea As Double(),
ByRef TTCombo As String(),
ByRef TTArea As Double(),
ByRef ErrorSummary As String(),
ByRef WarningSummary As String(),
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int GetSummaryResultsBeam(
String^ Name,
int% NumberItems,
array<String^>^% FrameName,
array<double>^% Location,
array<String^>^% TopCombo,
array<double>^% TopArea,
array<String^>^% BotCombo,
array<double>^% BotArea,
array<String^>^% VMajorCombo,
array<double>^% VMajorArea,
array<String^>^% TLCombo,
array<double>^% TLArea,
array<String^>^% TTCombo,
array<double>^% TTArea,
array<String^>^% ErrorSummary,
array<String^>^% WarningSummary,
eItemType ItemType = eItemType::Objects
)
abstract GetSummaryResultsBeam :
Name : string *
NumberItems : int byref *
FrameName : string[] byref *
Location : float[] byref *
TopCombo : string[] byref *
TopArea : float[] byref *
BotCombo : string[] byref *
BotArea : float[] byref *
VMajorCombo : string[] byref *
VMajorArea : float[] byref *
TLCombo : string[] byref *
TLArea : float[] byref *
TTCombo : string[] byref *
TTArea : float[] byref *
ErrorSummary : string[] byref *
WarningSummary : string[] byref *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing frame object or group,
depending on the value of the ItemType item.
- NumberItems
- Type: SystemInt32
The number of frame objects for which results are obtained.
- FrameName
- Type: SystemString
This is an array that includes each frame object name for which results are obtained.
- Location
- Type: SystemDouble
This is an array that includes the distance from the I-end of the frame object to the location where the results are reported. [L]
- TopCombo
- Type: SystemString
This is an array that includes the name of the design combination
for which the controlling top longitudinal rebar area for flexure occurs.
A combination name followed by (Sp) indicates that the design loads
were obtained by applying special, code-specific multipliers to all
or part of the specified design load combination, or that the design
was based on the capacity of other objects (or other design locations
for the same object).
- TopArea
- Type: SystemDouble
This is an array that includes the total top longitudinal rebar area
required for the flexure at the specified location. It does not include
the area of steel required for torsion. [L2]
- BotCombo
- Type: SystemString
This is an array that includes the name of the design combination
for which the controlling bottom longitudinal rebar area for flexure occurs.
A combination name followed by (Sp) indicates that the design loads
were obtained by applying special, code-specific, multipliers to all
or part of the specified design load combination, or that the design
was based on the capacity of other objects (or other design locations
for the same object).
- BotArea
- Type: SystemDouble
This is an array that includes the total bottom longitudinal rebar area
required for the flexure at the specified location. It does not include
the area of steel required for torsion. [L2]
- VMajorCombo
- Type: SystemString
- VMajorArea
- Type: SystemDouble
- TLCombo
- Type: SystemString
This is an array that includes the name of the design combination
for which the controlling longitudinal rebar area for torsion occurs.
A combination name followed by (Sp) indicates that the design loads
were obtained by applying special, code-specific, multipliers to all
or part of the specified design load combination, or that the design
was based on the capacity of other objects (or other design locations
for the same object).
- TLArea
- Type: SystemDouble
This is an array that includes the total longitudinal rebar area
required for torsion. [L2]
- TTCombo
- Type: SystemString
This is an array that includes the name of the design combination
for which the controlling transverse reinforcing for torsion occurs.
A combination name followed by (Sp) indicates that the design loads
were obtained by applying special, code-specific, multipliers to all
or part of the specified design load combination, or that the design was based
on the capacity of other objects (or other design locations for the same object).
- TTArea
- Type: SystemDouble
This is an array that includes the required area
of transverse torsional shear reinforcing per unit length
along the frame object for torsion at the specified location. [L2/L]
- ErrorSummary
- Type: SystemString
This is an array that includes the design error messages
for the frame object, if any.
- WarningSummary
- Type: SystemString
This is an array that includes the design warning messages
for the frame object, if any.
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the design results are retrieved
for the frame object specified by the Name item.
If this item is Group, the design results are retrieved
for all frame objects in the group specified by the Name item.
If this item is SelectedObjects,
the design results are retrieved for all selected frame objects,
and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the results are successfully retrieved;
otherwise it returns a nonzero value.
Remarks
Note that torsional design is only included for some codes.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
Dim NumberItems As Integer
Dim FrameName() As String
Dim Location() As Double
Dim TopCombo() As String
Dim TopArea() As Double
Dim BotCombo() As String
Dim BotArea() As Double
Dim VmajorCombo() As String
Dim VmajorArea() As Double
Dim TLCombo() As String
Dim TLArea() As Double
Dim TTCombo() As String
Dim TTArea() As Double
Dim ErrorSummary() As String
Dim WarningSummary() As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.PropMaterial.AddQuick(Name, eMatType.Rebar, , , , , eMatTypeRebar.ASTM_A706)
ret = SapModel.PropFrame.SetRectangle("COL", "4000Psi", 20, 20)
ret = SapModel.PropFrame.SetRectangle("BEAM", "4000Psi", 20, 12)
ret = SapModel.PropFrame.SetRebarBeam("BEAM", Name, Name, 2, 2, 2, 2, 2, 2)
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj("74", "BEAM")
System.IO.Directory.CreateDirectory("c:\CSI_API_temp")
ret = SapModel.File.Save("C:\CSI_API_temp\example.edb")
ret = SapModel.Analyze.RunAnalysis()
ret = SapModel.DesignConcrete.StartDesign()
ret = SapModel.DesignConcrete.GetSummaryResultsBeam("74", NumberItems, FrameName, Location, TopCombo, TopArea, BotCombo, BotArea, VmajorCombo, VmajorArea, TLCombo, TLArea, TTCombo, TTArea, ErrorSummary, WarningSummary)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also