cPropLinkSetFrictionIsolator Method

Initializes a friction isolator-type link property. If this function is called for an existing link property, all items for the property are reset to their default value.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetFrictionIsolator(
	string Name,
	ref bool[] DOF,
	ref bool[] Fixed,
	ref bool[] Nonlinear,
	ref double[] Ke,
	ref double[] Ce,
	ref double[] K,
	ref double[] Slow,
	ref double[] Fast,
	ref double[] Rate,
	ref double[] Radius,
	double Damping,
	double DJ2,
	double DJ3,
	string Notes = "",
	string GUID = ""
)

Parameters

Name
Type: SystemString
The name of an existing or new link property. If this is an existing property, that property is modified; otherwise, a new property is added
DOF
Type: SystemBoolean
Fixed
Type: SystemBoolean
This is a boolean array, dimensioned to 5, indicating if the specified degree of freedom is fixed (restrained).
ValueFixity
Fixed(0)U1 fixity if DOF(0) = True
Fixed(1)U2 fixity if DOF(1) = True
Fixed(2)U3 fixity if DOF(2) = True
Fixed(3)R1 fixity if DOF(3) = True
Fixed(4)R2 fixity if DOF(4) = True
Fixed(5)R3 fixity if DOF(5) = True
Nonlinear
Type: SystemBoolean
This is a boolean array, dimensioned to 5, indicating if nonlinear properties exist for a specified degree of freedom.
ValueNonlinear
Nonlinear(0)U1 has nonlinear properties
Nonlinear(1)U2 has nonlinear properties
Nonlinear(2)U3 has nonlinear properties
Nonlinear(3)R1, not used
Nonlinear(4)R2, not used
Nonlinear(5)R3, not used

Note that this item is applicable only for degrees of freedom U1, U2 and U3. For those degrees of freedom, the term Nonlinear(n) applies only when DOF(n) = True and Fixed(n) = False.

Ke
Type: SystemDouble
Ce
Type: SystemDouble
K
Type: SystemDouble
Slow
Type: SystemDouble
This is an array of the friction coefficient at zero velocity terms for the link property. This coefficient applies for nonlinear analyses.
ValueSlow
Slow(0)U1, not used
Slow(1)U2
Slow(2)U3
Slow(3)R1, not used
Slow(4)R2, not used
Slow(5)R3, not used

Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term Slow(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.

Fast
Type: SystemDouble
This is an array of the friction coefficient at fast velocity terms for the link property. This coefficient applies for nonlinear analyses.
ValueFast
Fast(0)U1, not used
Fast(1)U2
Fast(2)U3
Fast(3)R1, not used
Fast(4)R2, not used
Fast(5)R3, not used

Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term Fast(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.

Rate
Type: SystemDouble
This is an array of the inverse of the characteristic sliding velocity terms for the link property. This item applies for nonlinear analyses.
ValueRate
Rate(0)U1, not used
Rate(1)U2 [s/L]
Rate(2)U3 [s/L]
Rate(3)R1, not used
Rate(4)R2, not used
Rate(5)R3, not used

Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term Fast(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.

Radius
Type: SystemDouble
This is an array of the radius of the sliding contact surface terms for the link property. Inputting 0 means there is an infinite radius, that is, the slider is flat. This item applies for nonlinear analyses.
ValueRadius
Radius(0)U1, not used
Radius(1)U2 [L]
Radius(2)U3 [L]
Radius(3)R1, not used
Radius(4)R2, not used
Radius(5)R3, not used

Note that this item is applicable only for degrees of freedom U2 and U3. For those degrees of freedom, the term Fast(n) applies only when DOF(n) = True, Fixed(n) = False, and Nonlinear(n) = True.

Damping
Type: SystemDouble
DJ2
Type: SystemDouble
DJ3
Type: SystemDouble
Notes (Optional)
Type: SystemString
GUID (Optional)
Type: SystemString
The GUID (global unique identifier), if any, assigned to the property. If this item is input as Default, the program assigns a GUID to the property.

Return Value

Type: Int32
Returns zero if the property is successfully initialized; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim MyDOF() As Boolean
       Dim MyFixed() As Boolean
       Dim MyNonLinear() as Boolean
       Dim MyKe() As Double
       Dim MyCe() As Double
       Dim MyK() As Double
       Dim MySlow() As Double
       Dim MyFast() As Double
       Dim MyRate() As Double
       Dim MyRadius() As Double

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add link property
       ReDim MyDOF(5)
       ReDim MyFixed(5)
       ReDim MyNonLinear(5)
       ReDim MyKe(5)
       ReDim MyCe(5)
       ReDim MyK(5)
       ReDim MySlow(5)
       ReDim MyFast(5)
       ReDim MyRate(5)
       ReDim MyRadius(5)

       MyDOF(0) = True
       MyKe(0) = 12
       MyCe(0) = 0.01

       MyDOF(1) = True
       MyNonLinear(1) = True
       MyKe(1) = 12
       MyCe(1) = 0.01
       MyK(1) = 20
       MySlow(1)= 0.6
       MyFast(1)= 0.5
       MyRate(1)= 10
       MyRadius(1)= 80

       MyDOF(2) = True
       MyNonLinear(2) = True
       MyKe(2) = 14
       MyCe(2) = 0.008
       MyK(2) = 22
       MySlow(2)= 0.66
       MyFast(2)= 0.55
       MyRate(2)= 12
       MyRadius(2)= 75

       MyDOF(3) = True
       MyKe(3) = 15
       MyCe(3) = 0

       MyDOF(4) = True
       MyFixed(4) = True

       ret = SapModel.PropLink.SetFrictionIsolator("FI1", MyDOF, MyFixed, MyNonLinear, MyKe, MyCe, MyK, MySlow, MyFast, MyRate, MyRadius, 0.1, 2, 3)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also