cGroupGetAssignments Method |
Retrieves the assignments to a specified group
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetAssignments(
string Name,
ref int NumberItems,
ref int[] ObjectType,
ref string[] ObjectName
)
Function GetAssignments (
Name As String,
ByRef NumberItems As Integer,
ByRef ObjectType As Integer(),
ByRef ObjectName As String()
) As Integer
int GetAssignments(
String^ Name,
int% NumberItems,
array<int>^% ObjectType,
array<String^>^% ObjectName
)
abstract GetAssignments :
Name : string *
NumberItems : int byref *
ObjectType : int[] byref *
ObjectName : string[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing group
- NumberItems
- Type: SystemInt32
The number of assignments made to the specified group
- ObjectType
- Type: SystemInt32
This is an array that includes the object type of each item in the group.
- Point object
- Frame object
- Cable object
- Tendon object
- Area object
- Solid object
- Link object
- ObjectName
- Type: SystemString
This is an array that includes the name of each item in the group
Return Value
Type:
Int32
Returns zero if the group assignment is successfully retrieved, otherwise it returns a nonzero value
Remarks
See Also