cFileNewGridOnly Method

Creates a new grid-only model from template.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int NewGridOnly(
	int NumberStorys,
	double TypicalStoryHeight,
	double BottomStoryHeight,
	int NumberLinesX,
	int NumberLinesY,
	double SpacingX,
	double SpacingY
)

Parameters

NumberStorys
Type: SystemInt32
The number of stories in the model
TypicalStoryHeight
Type: SystemDouble
The story height that will be used for all stories in the model, except the bottom story. [L]
BottomStoryHeight
Type: SystemDouble
The story height will be used for the bottom story. [L]
NumberLinesX
Type: SystemInt32
The number of grid lines in the X direction.
NumberLinesY
Type: SystemInt32
The number of grid lines in the Y direction.
SpacingX
Type: SystemDouble
The uniform spacing for grid lines in the X direction. [L]
SpacingY
Type: SystemDouble
The uniform spacing for grid lines in the Y direction. [L]

Return Value

Type: Int32
Returns zero if the new grid only model is successfully created; otherwise it returns a nonzero value.
Remarks
Do not use this function to add to an existing model. This function should be used only for creating a new model and typically would be preceded by a call to InitializeNewModel(eUnits).
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create grid-only template model
       ret = SapModel.File.NewGridOnly(4,12,12,4,4,24,24)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also