Sets the group data.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetGroup(
string Name,
int Color = -1,
bool SpecifiedForSelection = true,
bool SpecifiedForSectionCutDefinition = true,
bool SpecifiedForSteelDesign = true,
bool SpecifiedForConcreteDesign = true,
bool SpecifiedForAluminumDesign = true,
bool SpecifiedForColdFormedDesign = true,
bool SpecifiedForStaticNLActiveStage = true,
bool SpecifiedForBridgeResponseOutput = true,
bool SpecifiedForAutoSeismicOutput = false,
bool SpecifiedForAutoWindOutput = false,
bool SpecifiedForMassAndWeight = true
)
Function SetGroup (
Name As String,
Optional Color As Integer = -1,
Optional SpecifiedForSelection As Boolean = true,
Optional SpecifiedForSectionCutDefinition As Boolean = true,
Optional SpecifiedForSteelDesign As Boolean = true,
Optional SpecifiedForConcreteDesign As Boolean = true,
Optional SpecifiedForAluminumDesign As Boolean = true,
Optional SpecifiedForColdFormedDesign As Boolean = true,
Optional SpecifiedForStaticNLActiveStage As Boolean = true,
Optional SpecifiedForBridgeResponseOutput As Boolean = true,
Optional SpecifiedForAutoSeismicOutput As Boolean = false,
Optional SpecifiedForAutoWindOutput As Boolean = false,
Optional SpecifiedForMassAndWeight As Boolean = true
) As Integer
int SetGroup(
String^ Name,
int Color = -1,
bool SpecifiedForSelection = true,
bool SpecifiedForSectionCutDefinition = true,
bool SpecifiedForSteelDesign = true,
bool SpecifiedForConcreteDesign = true,
bool SpecifiedForAluminumDesign = true,
bool SpecifiedForColdFormedDesign = true,
bool SpecifiedForStaticNLActiveStage = true,
bool SpecifiedForBridgeResponseOutput = true,
bool SpecifiedForAutoSeismicOutput = false,
bool SpecifiedForAutoWindOutput = false,
bool SpecifiedForMassAndWeight = true
)
abstract SetGroup :
Name : string *
?Color : int *
?SpecifiedForSelection : bool *
?SpecifiedForSectionCutDefinition : bool *
?SpecifiedForSteelDesign : bool *
?SpecifiedForConcreteDesign : bool *
?SpecifiedForAluminumDesign : bool *
?SpecifiedForColdFormedDesign : bool *
?SpecifiedForStaticNLActiveStage : bool *
?SpecifiedForBridgeResponseOutput : bool *
?SpecifiedForAutoSeismicOutput : bool *
?SpecifiedForAutoWindOutput : bool *
?SpecifiedForMassAndWeight : bool
(* Defaults:
let _Color = defaultArg Color -1
let _SpecifiedForSelection = defaultArg SpecifiedForSelection true
let _SpecifiedForSectionCutDefinition = defaultArg SpecifiedForSectionCutDefinition true
let _SpecifiedForSteelDesign = defaultArg SpecifiedForSteelDesign true
let _SpecifiedForConcreteDesign = defaultArg SpecifiedForConcreteDesign true
let _SpecifiedForAluminumDesign = defaultArg SpecifiedForAluminumDesign true
let _SpecifiedForColdFormedDesign = defaultArg SpecifiedForColdFormedDesign true
let _SpecifiedForStaticNLActiveStage = defaultArg SpecifiedForStaticNLActiveStage true
let _SpecifiedForBridgeResponseOutput = defaultArg SpecifiedForBridgeResponseOutput true
let _SpecifiedForAutoSeismicOutput = defaultArg SpecifiedForAutoSeismicOutput false
let _SpecifiedForAutoWindOutput = defaultArg SpecifiedForAutoWindOutput false
let _SpecifiedForMassAndWeight = defaultArg SpecifiedForMassAndWeight true
*)
-> int
Parameters
- Name
- Type: SystemString
This is the name of a group. If this is the name of an existing group,
that group is modified, otherwise a new group is added. - Color (Optional)
- Type: SystemInt32
- SpecifiedForSelection (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for selection; otherwise it is False. - SpecifiedForSectionCutDefinition (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining section cuts; otherwise it is False. - SpecifiedForSteelDesign (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining steel frame design groups; otherwise it is False. - SpecifiedForConcreteDesign (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining concrete frame design groups; otherwise it is False. - SpecifiedForAluminumDesign (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining aluminum frame design groups; otherwise it is False. - SpecifiedForColdFormedDesign (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining cold formed frame design groups; otherwise it is False. - SpecifiedForStaticNLActiveStage (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining stages for nonlinear static analysis; otherwise it is False. - SpecifiedForBridgeResponseOutput (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for reporting bridge response output; otherwise it is False. - SpecifiedForAutoSeismicOutput (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for reporting auto seismic loads; otherwise it is False. - SpecifiedForAutoWindOutput (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for reporting auto wind loads; otherwise it is False. - SpecifiedForMassAndWeight (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for reporting group masses and weight; otherwise it is False.
Return Value
Type:
Int32Returns zero if the group data is successfully set;
otherwise it returns a nonzero value.
RemarksItems
SpecifiedForAluminumDesign,
SpecifiedForColdFormedDesignSpecifiedForBridgeResponseOutput are not supported in ETABS.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.GroupDef.SetGroup("Group1")
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also