cLinkObjAddByPoint Method |
Adds a new link object whose end points are specified by name.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint AddByPoint(
string Point1,
string Point2,
ref string Name,
bool IsSingleJoint = false,
string PropName = "Default",
string UserName = ""
)
Function AddByPoint (
Point1 As String,
Point2 As String,
ByRef Name As String,
Optional IsSingleJoint As Boolean = false,
Optional PropName As String = "Default",
Optional UserName As String = ""
) As Integer
int AddByPoint(
String^ Point1,
String^ Point2,
String^% Name,
bool IsSingleJoint = false,
String^ PropName = L"Default",
String^ UserName = L""
)
abstract AddByPoint :
Point1 : string *
Point2 : string *
Name : string byref *
?IsSingleJoint : bool *
?PropName : string *
?UserName : string
(* Defaults:
let _IsSingleJoint = defaultArg IsSingleJoint false
let _PropName = defaultArg PropName "Default"
let _UserName = defaultArg UserName ""
*)
-> int
Parameters
- Point1
- Type: SystemString
The name of a defined point object at the I-End of the added link object. - Point2
- Type: SystemString
The name of a defined point object at the J-End of the added link object.
This item is ignored if the IsSingleJoint item is True.
- Name
- Type: SystemString
This is the name that the program ultimately assigns for the link object.
If no UserName is specified, the program assigns a default name to the
link object. If a UserName is specified and that name is not used for
another link object, the UserName is assigned to the link object;
otherwise a default name is assigned to the link object. - IsSingleJoint (Optional)
- Type: SystemBoolean
This item is True if a one-joint link is added and False
if a two-joint link is added. - PropName (Optional)
- Type: SystemString
This is either Default or the name of a defined link property.
If it is Default the program assigns a default link property to the link object.
If it is the name of a defined link property, that property is assigned to the link object
- UserName (Optional)
- Type: SystemString
Return Value
Type:
Int32Returns zero if the link object is successfully added;
otherwise it returns a nonzero value.
RemarksOne-joint links are not supported in ETABS.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name1 As String
Dim Name2 As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.LinkObj.AddByPoint("2", "4", Name1)
ret = SapModel.LinkObj.AddByPoint("1", "5", Name2)
ret = SapModel.View.RefreshView
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also