cPropRebarGetNameListWithData Method |
Retrieves the names and data of all defined rebar properties
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetNameListWithData(
ref int NumberNames,
ref string[] MyName,
ref double[] Areas,
ref double[] Diameters,
ref string[] MyGUID
)
Function GetNameListWithData (
ByRef NumberNames As Integer,
ByRef MyName As String(),
ByRef Areas As Double(),
ByRef Diameters As Double(),
ByRef MyGUID As String()
) As Integer
int GetNameListWithData(
int% NumberNames,
array<String^>^% MyName,
array<double>^% Areas,
array<double>^% Diameters,
array<String^>^% MyGUID
)
abstract GetNameListWithData :
NumberNames : int byref *
MyName : string[] byref *
Areas : float[] byref *
Diameters : float[] byref *
MyGUID : string[] byref -> int
Parameters
- NumberNames
- Type: SystemInt32
The numbe rof rebar properties
- MyName
- Type: SystemString
This is a one-dimensional array of rebar property names. The MyName array is created
as a dynamic, zero-based, array by the API user:
Dim MyName() as String
The array is dimensioned to (NumberNames – 1)
inside the ETABS program, filled with the names, and returned to the API user.
- Areas
- Type: SystemDouble
- Diameters
- Type: SystemDouble
- MyGUID
- Type: SystemString
This is a one-dimensional array of rebar property GUIDs.
Return Value
Type:
Int32
Returns zero if the data is successfully retrieved, otherwise it returns nonzero
Remarks
See Also