cDesignSteelGetSummaryResults Method |
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetSummaryResults(
string Name,
ref int NumberItems,
ref string[] FrameName,
ref double[] Ratio,
ref int[] RatioType,
ref double[] Location,
ref string[] ComboName,
ref string[] ErrorSummary,
ref string[] WarningSummary,
eItemType ItemType = eItemType.Objects
)
Function GetSummaryResults (
Name As String,
ByRef NumberItems As Integer,
ByRef FrameName As String(),
ByRef Ratio As Double(),
ByRef RatioType As Integer(),
ByRef Location As Double(),
ByRef ComboName As String(),
ByRef ErrorSummary As String(),
ByRef WarningSummary As String(),
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int GetSummaryResults(
String^ Name,
int% NumberItems,
array<String^>^% FrameName,
array<double>^% Ratio,
array<int>^% RatioType,
array<double>^% Location,
array<String^>^% ComboName,
array<String^>^% ErrorSummary,
array<String^>^% WarningSummary,
eItemType ItemType = eItemType::Objects
)
abstract GetSummaryResults :
Name : string *
NumberItems : int byref *
FrameName : string[] byref *
Ratio : float[] byref *
RatioType : int[] byref *
Location : float[] byref *
ComboName : string[] byref *
ErrorSummary : string[] byref *
WarningSummary : string[] byref *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
- NumberItems
- Type: SystemInt32
- FrameName
- Type: SystemString
- Ratio
- Type: SystemDouble
- RatioType
- Type: SystemInt32
- Location
- Type: SystemDouble
- ComboName
- Type: SystemString
- ErrorSummary
- Type: SystemString
- WarningSummary
- Type: SystemString
- ItemType (Optional)
- Type: ETABS2016eItemType
Return Value
Type:
Int32
See Also