cDesignConcreteGetSummaryResultsColumn Method |
Retrieves column summary results for concrete design
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetSummaryResultsColumn(
string Name,
ref int NumberItems,
ref string[] FrameName,
ref int[] MyOption,
ref double[] Location,
ref string[] PMMCombo,
ref double[] PMMArea,
ref double[] PMMRatio,
ref string[] VMajorCombo,
ref double[] AVMajor,
ref string[] VMinorCombo,
ref double[] AVMinor,
ref string[] ErrorSummary,
ref string[] WarningSummary,
eItemType ItemType = eItemType.Objects
)
Function GetSummaryResultsColumn (
Name As String,
ByRef NumberItems As Integer,
ByRef FrameName As String(),
ByRef MyOption As Integer(),
ByRef Location As Double(),
ByRef PMMCombo As String(),
ByRef PMMArea As Double(),
ByRef PMMRatio As Double(),
ByRef VMajorCombo As String(),
ByRef AVMajor As Double(),
ByRef VMinorCombo As String(),
ByRef AVMinor As Double(),
ByRef ErrorSummary As String(),
ByRef WarningSummary As String(),
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int GetSummaryResultsColumn(
String^ Name,
int% NumberItems,
array<String^>^% FrameName,
array<int>^% MyOption,
array<double>^% Location,
array<String^>^% PMMCombo,
array<double>^% PMMArea,
array<double>^% PMMRatio,
array<String^>^% VMajorCombo,
array<double>^% AVMajor,
array<String^>^% VMinorCombo,
array<double>^% AVMinor,
array<String^>^% ErrorSummary,
array<String^>^% WarningSummary,
eItemType ItemType = eItemType::Objects
)
abstract GetSummaryResultsColumn :
Name : string *
NumberItems : int byref *
FrameName : string[] byref *
MyOption : int[] byref *
Location : float[] byref *
PMMCombo : string[] byref *
PMMArea : float[] byref *
PMMRatio : float[] byref *
VMajorCombo : string[] byref *
AVMajor : float[] byref *
VMinorCombo : string[] byref *
AVMinor : float[] byref *
ErrorSummary : string[] byref *
WarningSummary : string[] byref *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing frame object or group,
depending on the value of the ItemType item.
- NumberItems
- Type: SystemInt32
The number of frame objects for which results are obtained.
- FrameName
- Type: SystemString
This is an array that includes each frame object name for which results are obtained.
- MyOption
- Type: SystemInt32
This is an array that includes 1 or 2, indicating the design option for each frame object
- Check
- Design
- Location
- Type: SystemDouble
This is an array that includes the distance from the I-end of the frame object
to the location where the results are reported. [L]
- PMMCombo
- Type: SystemString
This is an array that includes the name of the design combination for which the controlling PMM ratio or rebar area occurs.
A combination name followed by (Sp) indicates that the design loads were obtained by applying special,
code-specific multipliers to all or part of the specified design load combination,
or that the design was based on the capacity of other objects (or other design locations for the same object).
- PMMArea
- Type: SystemDouble
This is an array that includes the total longitudinal rebar area required
for the axial force plus biaxial moment (PMM) design at the specified location. [L2]
This item applies only when MyOption = 2 (design).
- PMMRatio
- Type: SystemDouble
This is an array that includes the axial force plus biaxial moment (PMM) stress ratio at the specified location
This item applies only when MyOption = 1 (check).
- VMajorCombo
- Type: SystemString
This is an array that includes the name of the design combination for which the controlling major shear occurs.
- AVMajor
- Type: SystemDouble
This is an array that includes the required area of transverse shear reinforcing per unit length along the frame object
for major shear at the specified location. [L2/L]
- VMinorCombo
- Type: SystemString
This is an array that includes the name of the design combination for which the controlling minor shear occurs.
- AVMinor
- Type: SystemDouble
This is an array that includes the required area of transverse shear reinforcing per unit length along the frame object
for minor shear at the specified location. [L2/L]
- ErrorSummary
- Type: SystemString
This is an array that includes the design error messages for the frame object, if any.
- WarningSummary
- Type: SystemString
This is an array that includes the design warning messages for the frame object, if any.
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the design results are retrieved
for the frame object specified by the Name item.
If this item is Group, the design results are retrieved
for all frame objects in the group specified by the Name item.
If this item is SelectedObjects,
the design results are retrieved for all selected frame objects,
and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the results are successfully retrieved; otherwise it returns a nonzero value
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
Dim NumberItems As Integer
Dim FrameName() As String
Dim MyOption() As Integer
Dim Location() As Double
Dim PMMCombo() As String
Dim PMMArea() As Double
Dim PMMRatio() As Double
Dim VmajorCombo() As String
Dim AVmajor() As Double
Dim VminorCombo() As String
Dim AVminor() As Double
Dim ErrorSummary() As String
Dim WarningSummary() As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.PropMaterial.AddQuick(Name, eMatType.Rebar, , , , , eMatTypeRebar.ASTM_A706)
ret = SapModel.PropFrame.SetRectangle("COL", "4000Psi", 20, 20)
ret = SapModel.PropFrame.SetRectangle("BEAM", "4000Psi", 20, 12)
ret = SapModel.PropFrame.SetRebarBeam("BEAM", Name, Name, 2, 2, 2, 2, 2, 2)
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj("4", "COL")
System.IO.Directory.CreateDirectory("c:\CSI_API_temp")
ret = SapModel.File.Save("C:\CSI_API_temp\example.edb")
ret = SapModel.Analyze.RunAnalysis()
ret = SapModel.DesignConcrete.StartDesign()
ret = SapModel.DesignConcrete.GetSummaryResultsColumn("4", NumberItems, FrameName, MyOption, Location, PMMCombo, PMMArea, PMMRatio, VmajorCombo, AVmajor, VminorCombo, AVminor, ErrorSummary, WarningSummary)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also