cAreaObjSetProperty Method

Assigns an area property to area objects.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetProperty(
	string Name,
	string PropName,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: SystemString
The name of an existing area object or group, depending on the value of the ItemType item.
PropName
Type: SystemString
This is None or the name of a area property to be assigned to the specified area object(s). None means that no property is assigned to the area object.
ItemType (Optional)
Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the assignment is made to the area object specified by the Name item.

If this item is Group, the assignment is made to all area objects in the group specified by the Name item.

If this item is SelectedObjects, assignment is made to all selected area objects, and the Name item is ignored.

Return Value

Type: Int32
Returns zero if the property is successfully assigned; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
   ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'set area property
   ret = SapModel.AreaObj.SetProperty("4", "None")

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also