cDetailingGetDetailedColumnStackData Method |
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetDetailedColumnStackData(
string ColumnStackID,
ref string[] ObjectUniqueNames,
ref int NumLongBarSets,
ref int[] NumLongBars,
ref double[] LongBarDiameter,
ref string[] LongBarNotation,
ref double[] LongBarStartDist,
ref int[] LongBarStartBend,
ref int[] LongBarEndBend,
ref double[] LongBarLength,
ref int[] LongBarNumLayers,
ref int NumTieZones,
ref string[] TieBarZones,
ref int[] NumTieBars,
ref int[] NumTieVertLegs,
ref double[] TieBarDiameter,
ref string[] TieBarNotation,
ref double[] TieBarStartDist,
ref double[] TieBarSpacing,
ref int[] TieBarType
)
Function GetDetailedColumnStackData (
ColumnStackID As String,
ByRef ObjectUniqueNames As String(),
ByRef NumLongBarSets As Integer,
ByRef NumLongBars As Integer(),
ByRef LongBarDiameter As Double(),
ByRef LongBarNotation As String(),
ByRef LongBarStartDist As Double(),
ByRef LongBarStartBend As Integer(),
ByRef LongBarEndBend As Integer(),
ByRef LongBarLength As Double(),
ByRef LongBarNumLayers As Integer(),
ByRef NumTieZones As Integer,
ByRef TieBarZones As String(),
ByRef NumTieBars As Integer(),
ByRef NumTieVertLegs As Integer(),
ByRef TieBarDiameter As Double(),
ByRef TieBarNotation As String(),
ByRef TieBarStartDist As Double(),
ByRef TieBarSpacing As Double(),
ByRef TieBarType As Integer()
) As Integer
int GetDetailedColumnStackData(
String^ ColumnStackID,
array<String^>^% ObjectUniqueNames,
int% NumLongBarSets,
array<int>^% NumLongBars,
array<double>^% LongBarDiameter,
array<String^>^% LongBarNotation,
array<double>^% LongBarStartDist,
array<int>^% LongBarStartBend,
array<int>^% LongBarEndBend,
array<double>^% LongBarLength,
array<int>^% LongBarNumLayers,
int% NumTieZones,
array<String^>^% TieBarZones,
array<int>^% NumTieBars,
array<int>^% NumTieVertLegs,
array<double>^% TieBarDiameter,
array<String^>^% TieBarNotation,
array<double>^% TieBarStartDist,
array<double>^% TieBarSpacing,
array<int>^% TieBarType
)
abstract GetDetailedColumnStackData :
ColumnStackID : string *
ObjectUniqueNames : string[] byref *
NumLongBarSets : int byref *
NumLongBars : int[] byref *
LongBarDiameter : float[] byref *
LongBarNotation : string[] byref *
LongBarStartDist : float[] byref *
LongBarStartBend : int[] byref *
LongBarEndBend : int[] byref *
LongBarLength : float[] byref *
LongBarNumLayers : int[] byref *
NumTieZones : int byref *
TieBarZones : string[] byref *
NumTieBars : int[] byref *
NumTieVertLegs : int[] byref *
TieBarDiameter : float[] byref *
TieBarNotation : string[] byref *
TieBarStartDist : float[] byref *
TieBarSpacing : float[] byref *
TieBarType : int[] byref -> int
Parameters
- ColumnStackID
- Type: SystemString
- ObjectUniqueNames
- Type: SystemString
- NumLongBarSets
- Type: SystemInt32
- NumLongBars
- Type: SystemInt32
- LongBarDiameter
- Type: SystemDouble
- LongBarNotation
- Type: SystemString
- LongBarStartDist
- Type: SystemDouble
- LongBarStartBend
- Type: SystemInt32
- LongBarEndBend
- Type: SystemInt32
- LongBarLength
- Type: SystemDouble
- LongBarNumLayers
- Type: SystemInt32
- NumTieZones
- Type: SystemInt32
- TieBarZones
- Type: SystemString
- NumTieBars
- Type: SystemInt32
- NumTieVertLegs
- Type: SystemInt32
- TieBarDiameter
- Type: SystemDouble
- TieBarNotation
- Type: SystemString
- TieBarStartDist
- Type: SystemDouble
- TieBarSpacing
- Type: SystemDouble
- TieBarType
- Type: SystemInt32
Return Value
Type:
Int32
See Also