cStoryGetSimilarTo Method

Retrieves whether a story is a master story, and if not, which master story it is similar to

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetSimilarTo(
	string Name,
	ref bool IsMasterStory,
	ref string SimilarToStory
)

Parameters

Name
Type: SystemString
The name of a defined story
IsMasterStory
Type: SystemBoolean
True if the story is a master story, False otherwise
SimilarToStory
Type: SystemString
If IsMasterStory is False then this is the master story that the requested story is similar to.

Return Value

Type: Int32
Returns zero if the value is successfully retrieved, otherwise returns nonzero.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim MasterStory As Boolean
       Dim SimilarToStory As String

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'get story similar data
       ret = SapModel.Story.GetSimilarTo("Story2", MasterStory, SimilarToStory)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also