cPropLinkSetMultiLinearPlastic Method

Initializes a multilinear plastic-type link property. If this function is called for an existing link property, all items for the property are reset to their default values.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetMultiLinearPlastic(
	string Name,
	ref bool[] DOF,
	ref bool[] Fixed,
	ref bool[] Nonlinear,
	ref double[] Ke,
	ref double[] Ce,
	double DJ2,
	double DJ3,
	string Notes = "",
	string GUID = ""
)

Parameters

Name
Type: SystemString
The name of an existing or new link property. If this is an existing property, that property is modified; otherwise, a new property is added
DOF
Type: SystemBoolean
Fixed
Type: SystemBoolean
This is a boolean array, dimensioned to 5, indicating if the specified degree of freedom is fixed (restrained).
ValueFixity
Fixed(0)U1 fixity if DOF(0) = True
Fixed(1)U2 fixity if DOF(1) = True
Fixed(2)U3 fixity if DOF(2) = True
Fixed(3)R1 fixity if DOF(3) = True
Fixed(4)R2 fixity if DOF(4) = True
Fixed(5)R3 fixity if DOF(5) = True

The term Fixed(n) applies only when DOF(n) = True.

Nonlinear
Type: SystemBoolean
This is a boolean array, dimensioned to 5, indicating if nonlinear properties exist for a specified degree of freedom.
ValueNonlinear
Nonlinear(0)U1 has nonlinear properties
Nonlinear(1)U2 has nonlinear properties
Nonlinear(2)U3 has nonlinear properties
Nonlinear(3)R1 has nonlinear properties
Nonlinear(4)R2 has nonlinear properties
Nonlinear(5)R3 has nonlinear properties

The term Nonlinear(n) applies only when DOF(n) = True and Fixed(n) = False.

Ke
Type: SystemDouble
Ce
Type: SystemDouble
DJ2
Type: SystemDouble
DJ3
Type: SystemDouble
Notes (Optional)
Type: SystemString
GUID (Optional)
Type: SystemString
The GUID (global unique identifier), if any, assigned to the property. If this item is input as Default, the program assigns a GUID to the property.

Return Value

Type: Int32
Returns zero if the property is successfully initialized; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1
       Dim MyDOF() As Boolean
       Dim MyFixed() As Boolean
       Dim MyNonLinear() as Boolean
       Dim MyKe() As Double
       Dim MyCe() As Double

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'add link property
       ReDim MyDOF(5)
       ReDim MyFixed(5)
       ReDim MyNonLinear(5)
       ReDim MyKe(5)
       ReDim MyCe(5)

       MyDOF(0) = True
       MyKe(0) = 12
       MyCe(0) = 0.01

       MyDOF(1) = True
       MyNonLinear(1) = True
       MyKe(1) = 12
       MyCe(1) = 0.01

       MyDOF(2) = True
       MyFixed(2) = True

       ret = SapModel.PropLink.SetMultiLinearPlastic("MLP1", MyDOF, MyFixed, MyNonLinear, MyKe, MyCe, 2, 0)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also