Sets the group data. Primarily for ETABS
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetGroup_1(
string Name,
int color = -1,
bool SpecifiedForSelection = true,
bool SpecifiedForSectionCutDefinition = true,
bool SpecifiedForSteelDesign = true,
bool SpecifiedForConcreteDesign = true,
bool SpecifiedForAluminumDesign = true,
bool SpecifiedForStaticNLActiveStage = true,
bool SpecifiedForAutoSeismicOutput = false,
bool SpecifiedForAutoWindOutput = false,
bool SpecifiedForMassAndWeight = true,
bool SpecifiedForSteelJoistDesign = true,
bool SpecifiedForWallDesign = true,
bool SpecifiedForBasePlateDesign = true,
bool SpecifiedForConnectionDesign = true
)
Function SetGroup_1 (
Name As String,
Optional color As Integer = -1,
Optional SpecifiedForSelection As Boolean = true,
Optional SpecifiedForSectionCutDefinition As Boolean = true,
Optional SpecifiedForSteelDesign As Boolean = true,
Optional SpecifiedForConcreteDesign As Boolean = true,
Optional SpecifiedForAluminumDesign As Boolean = true,
Optional SpecifiedForStaticNLActiveStage As Boolean = true,
Optional SpecifiedForAutoSeismicOutput As Boolean = false,
Optional SpecifiedForAutoWindOutput As Boolean = false,
Optional SpecifiedForMassAndWeight As Boolean = true,
Optional SpecifiedForSteelJoistDesign As Boolean = true,
Optional SpecifiedForWallDesign As Boolean = true,
Optional SpecifiedForBasePlateDesign As Boolean = true,
Optional SpecifiedForConnectionDesign As Boolean = true
) As Integer
int SetGroup_1(
String^ Name,
int color = -1,
bool SpecifiedForSelection = true,
bool SpecifiedForSectionCutDefinition = true,
bool SpecifiedForSteelDesign = true,
bool SpecifiedForConcreteDesign = true,
bool SpecifiedForAluminumDesign = true,
bool SpecifiedForStaticNLActiveStage = true,
bool SpecifiedForAutoSeismicOutput = false,
bool SpecifiedForAutoWindOutput = false,
bool SpecifiedForMassAndWeight = true,
bool SpecifiedForSteelJoistDesign = true,
bool SpecifiedForWallDesign = true,
bool SpecifiedForBasePlateDesign = true,
bool SpecifiedForConnectionDesign = true
)
abstract SetGroup_1 :
Name : string *
?color : int *
?SpecifiedForSelection : bool *
?SpecifiedForSectionCutDefinition : bool *
?SpecifiedForSteelDesign : bool *
?SpecifiedForConcreteDesign : bool *
?SpecifiedForAluminumDesign : bool *
?SpecifiedForStaticNLActiveStage : bool *
?SpecifiedForAutoSeismicOutput : bool *
?SpecifiedForAutoWindOutput : bool *
?SpecifiedForMassAndWeight : bool *
?SpecifiedForSteelJoistDesign : bool *
?SpecifiedForWallDesign : bool *
?SpecifiedForBasePlateDesign : bool *
?SpecifiedForConnectionDesign : bool
(* Defaults:
let _color = defaultArg color -1
let _SpecifiedForSelection = defaultArg SpecifiedForSelection true
let _SpecifiedForSectionCutDefinition = defaultArg SpecifiedForSectionCutDefinition true
let _SpecifiedForSteelDesign = defaultArg SpecifiedForSteelDesign true
let _SpecifiedForConcreteDesign = defaultArg SpecifiedForConcreteDesign true
let _SpecifiedForAluminumDesign = defaultArg SpecifiedForAluminumDesign true
let _SpecifiedForStaticNLActiveStage = defaultArg SpecifiedForStaticNLActiveStage true
let _SpecifiedForAutoSeismicOutput = defaultArg SpecifiedForAutoSeismicOutput false
let _SpecifiedForAutoWindOutput = defaultArg SpecifiedForAutoWindOutput false
let _SpecifiedForMassAndWeight = defaultArg SpecifiedForMassAndWeight true
let _SpecifiedForSteelJoistDesign = defaultArg SpecifiedForSteelJoistDesign true
let _SpecifiedForWallDesign = defaultArg SpecifiedForWallDesign true
let _SpecifiedForBasePlateDesign = defaultArg SpecifiedForBasePlateDesign true
let _SpecifiedForConnectionDesign = defaultArg SpecifiedForConnectionDesign true
*)
-> int
Parameters
- Name
- Type: SystemString
This is the name of a group. If this is the name of an existing group,
that group is modified, otherwise a new group is added. - color (Optional)
- Type: SystemInt32
The display color for the group specified as a Integer.
If this value is input as –1, the program automatically selects a display color for the group. - SpecifiedForSelection (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for selection; otherwise it is False. - SpecifiedForSectionCutDefinition (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining section cuts; otherwise it is False. - SpecifiedForSteelDesign (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining steel frame design groups; otherwise it is False. - SpecifiedForConcreteDesign (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining concrete frame design groups; otherwise it is False. - SpecifiedForAluminumDesign (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining aluminum frame design groups; otherwise it is False. - SpecifiedForStaticNLActiveStage (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining stages for nonlinear static analysis; otherwise it is False. - SpecifiedForAutoSeismicOutput (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for reporting auto seismic loads; otherwise it is False. - SpecifiedForAutoWindOutput (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for reporting auto wind loads; otherwise it is False. - SpecifiedForMassAndWeight (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for reporting group masses and weight; otherwise it is False. - SpecifiedForSteelJoistDesign (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining steel joist design groups; otherwise it is False. - SpecifiedForWallDesign (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining wall design groups; otherwise it is False. - SpecifiedForBasePlateDesign (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining base plate design groups; otherwise it is False. - SpecifiedForConnectionDesign (Optional)
- Type: SystemBoolean
This item is True if the group is specified to be
used for defining connection design groups; otherwise it is False.
Return Value
Type:
Int32Returns zero if the group data is successfully set;
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.GroupDef.SetGroup_1("Group1")
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also