cDetailingGetColumnTieRebarData Method

Retrieves tie (confinement/shear) rebar data for a column frame object

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetColumnTieRebarData(
	string Name,
	ref int NumberRebarSets,
	ref string[] BarSizeName,
	ref double[] BarArea,
	ref int[] Pattern,
	ref int[] ConfineType,
	ref int[] NumberLegs2Dir,
	ref int[] NumberLegs3Dir,
	ref string[] Location,
	ref double[] ClearCover,
	ref double[] StartCoord1,
	ref double[] Spacing,
	ref double[] Heights,
	ref string[] RebarSetGUID
)

Parameters

Name
Type: SystemString
The name of an existing beam frame object
NumberRebarSets
Type: SystemInt32
Number of tie rebar sets for this beam object
BarSizeName
Type: SystemString
Rebar designation
BarArea
Type: SystemDouble
Individual rebar area
Pattern
Type: SystemInt32
Rebar pattern - 1 - Rectangular, 2 - Circular
ConfineType
Type: SystemInt32
Confinement type - 1 - Ties, 2 - Spiral (Spiral only possible when Pattern is Circular)
NumberLegs2Dir
Type: SystemInt32
Number of legs for ties in this set along the local 2 direction)
NumberLegs3Dir
Type: SystemInt32
Number of legs for ties in this set along the local 3 direction)
Location
Type: SystemString
Zone of this set of rebars - A, B, C, etc. (See picture for seismic/ non-seismic detailing)
ClearCover
Type: SystemDouble
Clear cover from face to ties being specified
StartCoord1
Type: SystemDouble
Start of this set of tie rebars from start/end (depends on location) of column object
Spacing
Type: SystemDouble
Spacing of ties
Heights
Type: SystemDouble
Height over which these tie bars are provided from start point
RebarSetGUID
Type: SystemString
The GUIDs of each of the rebar sets (could be duplicated for adjacent beam if rebars are continuous)

Return Value

Type: Int32
Returns zero if the rebar data is successfully retrieved; otherwise it returns a nonzero value.
See Also