cCaseStaticNonlinearSetCase Method

Initializes a static nonlinear load case.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetCase(
	string Name
)

Parameters

Name
Type: SystemString
The name of an existing or new load case. If this is an existing case, that case is modified; otherwise, a new case is added.

Return Value

Type: Int32
Returns zero if the load case is successfully initialized; otherwise it returns a nonzero value.
Remarks
If this function is called for an existing load case, all items for the case are reset to their default value.
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
    ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'add static nonlinear load case
    ret = SapModel.LoadCases.StaticNonlinear.SetCase("LCASE1")

'refresh view
   ret = SapModel.View.RefreshView(0, False)

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also