cPropTendonGetProp Method |
Retrieves tendon property definition data.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetProp(
string Name,
ref string MatProp,
ref int ModelingOption,
ref double Area,
ref int Color,
ref string Notes,
ref string GUID
)
Function GetProp (
Name As String,
ByRef MatProp As String,
ByRef ModelingOption As Integer,
ByRef Area As Double,
ByRef Color As Integer,
ByRef Notes As String,
ByRef GUID As String
) As Integer
int GetProp(
String^ Name,
String^% MatProp,
int% ModelingOption,
double% Area,
int% Color,
String^% Notes,
String^% GUID
)
abstract GetProp :
Name : string *
MatProp : string byref *
ModelingOption : int byref *
Area : float byref *
Color : int byref *
Notes : string byref *
GUID : string byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing tendon property. - MatProp
- Type: SystemString
The name of the material property assigned to the tendon property. - ModelingOption
- Type: SystemInt32
This is either 1 or 2, indicating the tendon modeling option.
Value | Modeling Option |
---|
1 | Model tendon as loads |
2 | Model tendon as elements |
- Area
- Type: SystemDouble
The cross-sectional area of the tendon. [L2] - Color
- Type: SystemInt32
- Notes
- Type: SystemString
- GUID
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the property.
Return Value
Type:
Int32Returns zero if the property is successfully retrieved; otherwise it returns a nonzero value.
RemarksModeling tendons as elements (
ModelingOption = 2) is not supported in ETABS.
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim Name As String
Dim MatProp As String
Dim ModelingOption As Integer
Dim Area As Double
Dim Color As Integer
Dim Notes As String
Dim GUID As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)
ret = SapModel.PropMaterial.AddQuick(Name, eMatType.Tendon, , , , , , eMatTypeTendon.ASTM_A416Gr270)
ret = SapModel.PropTendon.SetProp("T1", Name, 1, 2.25)
ret = SapModel.PropTendon.GetProp("T1", MatProp, ModelingOption, Area, Color, Notes, GUID)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also