cSpandrelLabelGetSpandrel Method

Retrieves the specified Spandrel Label

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetSpandrel(
	string Name,
	ref bool IsMultiStory
)

Parameters

Name
Type: SystemString
The name of an existing Spandrel Label
IsMultiStory
Type: SystemBoolean
Whether the Spandrel Label spans multiple story levels

Return Value

Type: Int32
Returns zero if the Spandrel Label exists, otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1
   Dim IsMultiStory As Boolean

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
   ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'define new Spandrel label
    ret = SapModel.SpandrelLabel.SetSpandrel("MySpandrel", False)

'check Spandrel label
    ret = SapModel.SpandrelLabel.GetSpandrel("MySpandrel", IsMultiStory)

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also