cAreaObjGetLoadUniformToFrame Method |
Retrieves the uniform to frame load assignments to area objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetLoadUniformToFrame(
string Name,
ref int NumberItems,
ref string[] AreaName,
ref string[] LoadPat,
ref string[] CSys,
ref int[] Dir,
ref double[] Value,
ref int[] DistType,
eItemType ItemType = eItemType.Objects
)
Function GetLoadUniformToFrame (
Name As String,
ByRef NumberItems As Integer,
ByRef AreaName As String(),
ByRef LoadPat As String(),
ByRef CSys As String(),
ByRef Dir As Integer(),
ByRef Value As Double(),
ByRef DistType As Integer(),
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int GetLoadUniformToFrame(
String^ Name,
int% NumberItems,
array<String^>^% AreaName,
array<String^>^% LoadPat,
array<String^>^% CSys,
array<int>^% Dir,
array<double>^% Value,
array<int>^% DistType,
eItemType ItemType = eItemType::Objects
)
abstract GetLoadUniformToFrame :
Name : string *
NumberItems : int byref *
AreaName : string[] byref *
LoadPat : string[] byref *
CSys : string[] byref *
Dir : int[] byref *
Value : float[] byref *
DistType : int[] byref *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing area object or group, depending on the value
of the ItemType item.
- NumberItems
- Type: SystemInt32
The total number of uniform to frame loads retrieved for the specified
area objects.
- AreaName
- Type: SystemString
This is an array that includes the name of the area object
associated with each uniform to frame load.
- LoadPat
- Type: SystemString
This is an array that includes the name of the load pattern associated
with each uniform to frame load.
- CSys
- Type: SystemString
This is an array that includes the name of the coordinate system
associated with each uniform to frame load.
- Dir
- Type: SystemInt32
- Value
- Type: SystemDouble
The uniform load value. [F/L^2]
- DistType
- Type: SystemInt32
This is either 1 or 2, indicating the load distribution type.
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignments are retrieved
for the area object specified by the Name item.
If this item is Group, the assignments are retrieved
for all area objects in the group specified by the Name item.
If this item is SelectedObjects, assignments are retrieved
for is made to all selected area objects, and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the load assignments are successfully retrieved;
otherwise it returns a nonzero value.
Remarks
See Also