cDetailingGetBeamLongRebarData Method |
Retrieves longitudinal rebar data for a beam frame object
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetBeamLongRebarData(
string Name,
ref int NumberRebarSets,
ref string[] BarSizeName,
ref double[] BarArea,
ref int[] NumberBars,
ref string[] Location,
ref double[] ClearCover,
ref double[] StartCoord1,
ref double[] BarLength,
ref double[] BendingAngleStart,
ref double[] BendingAngleEnd,
ref string[] RebarSetGUID
)
Function GetBeamLongRebarData (
Name As String,
ByRef NumberRebarSets As Integer,
ByRef BarSizeName As String(),
ByRef BarArea As Double(),
ByRef NumberBars As Integer(),
ByRef Location As String(),
ByRef ClearCover As Double(),
ByRef StartCoord1 As Double(),
ByRef BarLength As Double(),
ByRef BendingAngleStart As Double(),
ByRef BendingAngleEnd As Double(),
ByRef RebarSetGUID As String()
) As Integer
int GetBeamLongRebarData(
String^ Name,
int% NumberRebarSets,
array<String^>^% BarSizeName,
array<double>^% BarArea,
array<int>^% NumberBars,
array<String^>^% Location,
array<double>^% ClearCover,
array<double>^% StartCoord1,
array<double>^% BarLength,
array<double>^% BendingAngleStart,
array<double>^% BendingAngleEnd,
array<String^>^% RebarSetGUID
)
abstract GetBeamLongRebarData :
Name : string *
NumberRebarSets : int byref *
BarSizeName : string[] byref *
BarArea : float[] byref *
NumberBars : int[] byref *
Location : string[] byref *
ClearCover : float[] byref *
StartCoord1 : float[] byref *
BarLength : float[] byref *
BendingAngleStart : float[] byref *
BendingAngleEnd : float[] byref *
RebarSetGUID : string[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing beam frame object - NumberRebarSets
- Type: SystemInt32
Number of longitudinal rebar sets for this beam object - BarSizeName
- Type: SystemString
Rebar designation - BarArea
- Type: SystemDouble
Individual rebar area - NumberBars
- Type: SystemInt32
Number of rebars in this set - Location
- Type: SystemString
Location of this set of rebars - A, B, C, etc. (See picture for seismic/ non-seismic detailing) - ClearCover
- Type: SystemDouble
Clear cover from top or bottom beam face to longitudinal rebar being specified - StartCoord1
- Type: SystemDouble
Start of this set of rebars from start/end (depends on location) of beam object - BarLength
- Type: SystemDouble
Length of bars from start point - BendingAngleStart
- Type: SystemDouble
Bend angle if any at start of rebars - BendingAngleEnd
- Type: SystemDouble
Bend angle if any at end of rebars - RebarSetGUID
- Type: SystemString
The GUIDs of each of the rebar sets (could be duplicated for adjacent beam if rebars are continuous)
Return Value
Type:
Int32 Returns zero if the rebar data is successfully retrieved; otherwise it returns a nonzero value.
See Also