cPropArea GetWall Method CSi API ETABS 2015
Retrieves property data for a wall section.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int GetWall(
	string Name,
	ref eWallPropType WallPropType,
	ref eShellType ShellType,
	ref string MatProp,
	ref double Thickness,
	ref int color,
	ref string notes,
	ref string GUID
)

Parameters

Name
Type: OnlineSystem String
The name of an existing wall property.
WallPropType
Type: ETABS2015 eWallPropType 
This is one of the items in the eWallPropType enumeration.

If this item is AutoSelectList, use the GetWallAutoSelectList(String,  String  , String ) function to get additional parameters.

ShellType
Type: ETABS2015 eShellType 
This is one of the items in the eShellType enumeration.
MatProp
Type: OnlineSystem String 
The name of the material property for the area property.

This item does not apply when ShellType is Layered.

Thickness
Type: OnlineSystem Double 
The membrane thickness. [L]

This item does not apply when ShellType is Layered.

color
Type: OnlineSystem Int32 
The display color assigned to the property.
notes
Type: OnlineSystem String 
The notes, if any, assigned to the property.
GUID
Type: OnlineSystem String 
The GUID (global unique identifier), if any, assigned to the property.

Return Value

The function returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value.
Remarks

Examples

See Also