Reports the joint reactions for the specified point elements. The reactions reported are from
restraints, springs and grounded (one-joint) links.
Namespace: ETABS2015Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax
Parameters
- Name
- Type:
System String
The name of an existing point object, point element, or group of objects depending on the value of the ItemTypeElm item.
- ItemTypeElm
- Type: ETABS2015 eItemTypeElm
This is one of the following items in the eItemTypeElm enumeration.If this item is ObjectElm, the result request is for the point element corresponding to the point object specified by the Name item.
If this item is Element, the result request is for the point element specified by the Name item.
If this item is GroupElm, the result request is for all point elements directly or indirectly specified in the group specified by the Name item.
If this item is SelectionElm, the result request is for all point elements directly or indirectly selected and the Name item is ignored.
- NumberResults
- Type:
System Int32
The total number of results returned by the program.
- Obj
- Type:
System String
- Elm
- Type:
System String
- LoadCase
- Type:
System String
This is an array that includes the name of the analysis case or load combination associated with each result.
- StepType
- Type:
System String
This is an array that includes the step type, if any, for each result.
- StepNum
- Type:
System Double
This is an array that includes the step number, if any, for each result.
- F1
- Type:
System Double
- F2
- Type:
System Double
This is a one dimensional array that includes the reaction forces in the point element local 2 axis direction. [F].
- F3
- Type:
System Double
This is a one dimensional array that includes the reaction forces in the point element local 3 axis direction. [F].
- M1
- Type:
System Double
This is a one dimensional array that includes the reaction moments about the point element local 1 axis direction. [FL].
- M2
- Type:
System Double
This is a one dimensional array that includes the reaction moments about the point element local 2 axis direction. [FL].
- M3
- Type:
System Double
This is a one dimensional array that includes the reaction moments about the point element local 3 axis direction. [FL].
Return Value
Returns zero if the reactions are successfully recovered; otherwise it returns a nonzero value.Remarks
Examples
See Also