cAnalysisResults JointAcc Method CSi API ETABS 2015
Reports the joint accelerations for the specified point elements. The accelerations reported by this function are relative accelerations.

Namespace: ETABS2015
Assembly: ETABS2015 (in ETABS2015.dll) Version: 15.0.0.0 (15.0.0.0)
Syntax

int JointAcc(
	string Name,
	eItemTypeElm ItemTypeElm,
	ref int NumberResults,
	ref string[] Obj,
	ref string[] Elm,
	ref string[] LoadCase,
	ref string[] StepType,
	ref double[] StepNum,
	ref double[] U1,
	ref double[] U2,
	ref double[] U3,
	ref double[] R1,
	ref double[] R2,
	ref double[] R3
)

Parameters

Name
Type: OnlineSystem String
The name of an existing point object, point element, or group of objects depending on the value of the ItemTypeElm item.
ItemTypeElm
Type: ETABS2015 eItemTypeElm
This is one of the following items in the eItemTypeElm enumeration.

If this item is ObjectElm, the result request is for the point element corresponding to the point object specified by the Name item.

If this item is Element, the result request is for the point element specified by the Name item.

If this item is GroupElm, the result request is for all point elements directly or indirectly specified in the group specified by the Name item.

If this item is SelectionElm, the result request is for all point elements directly or indirectly selected and the Name item is ignored.

NumberResults
Type: OnlineSystem Int32 
The total number of results returned by the program.
Obj
Type:  OnlineSystem String  
Elm
Type:  OnlineSystem String  
LoadCase
Type:  OnlineSystem String  
This is an array that includes the name of the analysis case or load combination associated with each result.
StepType
Type:  OnlineSystem String  
This is an array that includes the step type, if any, for each result.
StepNum
Type:  OnlineSystem Double  
This is an array that includes the step number, if any, for each result.
U1
Type:  OnlineSystem Double  
This is a one dimensional array that includes the translational acceleration in the point element local 1 direction for each result. [L/s2]
U2
Type:  OnlineSystem Double  
This is a one dimensional array that includes the translational acceleration in the point element local 2 direction for each result. [L/s2]
U3
Type:  OnlineSystem Double  
This is a one dimensional array that includes the translational acceleration in the point element local 3 direction for each result. [L/s2]
R1
Type:  OnlineSystem Double  
This is a one dimensional array that includes the rotational acceleration in the point element local 1 direction for each result. [rad/s2]
R2
Type:  OnlineSystem Double  
This is a one dimensional array that includes the rotational acceleration in the point element local 2 direction for each result. [rad/s2]
R3
Type:  OnlineSystem Double  
This is a one dimensional array that includes the rotational acceleration in the point element local 3 direction for each result. [rad/s2]

Return Value

Returns zero if the accelerations are successfully recovered, otherwise it returns a nonzero value
Remarks

See Results for more information.
Examples

See Also