cPropFrameSDShapeGetSolidCircle Method |
Retrieves property data for a solid circle shape in a section designer section
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetSolidCircle(
string Name,
string ShapeName,
ref string MatProp,
ref string SSOverwrite,
ref int Color,
ref double XCenter,
ref double YCenter,
ref double Diameter,
ref bool Reinf,
ref int NumberBars,
ref double Rotation,
ref double Cover,
ref string RebarSize,
ref string MatRebar
)
Function GetSolidCircle (
Name As String,
ShapeName As String,
ByRef MatProp As String,
ByRef SSOverwrite As String,
ByRef Color As Integer,
ByRef XCenter As Double,
ByRef YCenter As Double,
ByRef Diameter As Double,
ByRef Reinf As Boolean,
ByRef NumberBars As Integer,
ByRef Rotation As Double,
ByRef Cover As Double,
ByRef RebarSize As String,
ByRef MatRebar As String
) As Integer
int GetSolidCircle(
String^ Name,
String^ ShapeName,
String^% MatProp,
String^% SSOverwrite,
int% Color,
double% XCenter,
double% YCenter,
double% Diameter,
bool% Reinf,
int% NumberBars,
double% Rotation,
double% Cover,
String^% RebarSize,
String^% MatRebar
)
abstract GetSolidCircle :
Name : string *
ShapeName : string *
MatProp : string byref *
SSOverwrite : string byref *
Color : int byref *
XCenter : float byref *
YCenter : float byref *
Diameter : float byref *
Reinf : bool byref *
NumberBars : int byref *
Rotation : float byref *
Cover : float byref *
RebarSize : string byref *
MatRebar : string byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property that is a section designer section
- ShapeName
- Type: SystemString
The name of an existing solid circle shape in the specified frame section property
- MatProp
- Type: SystemString
The name of the material property for the shape
- SSOverwrite
- Type: SystemString
This is a blank string, Default, or the name of a defined stress-strain curve.
If this item is a blank string or Default,
the shape stress-strain curve is based on the assigned material property.
- Color
- Type: SystemInt32
The fill color assigned to the shape
- XCenter
- Type: SystemDouble
The X-coordinate of the center of the shape in the section designer coordinate system. [L]
- YCenter
- Type: SystemDouble
The Y-coordinate of the center of the shape in the section designer coordinate system. [L]
- Diameter
- Type: SystemDouble
The diameter of the circle.[L]
- Reinf
- Type: SystemBoolean
This item is True when there is edge and corner reinforcing steel associated with the shape.
The MatProp item must refer to a concrete material for this item to be True.
- NumberBars
- Type: SystemInt32
This item is visible only if the Reinf item is set to True.
It is the number of equally spaced bars for the circular reinforcing.
- Rotation
- Type: SystemDouble
The counter clockwise rotation of the shape from its default orientation. [deg]
- Cover
- Type: SystemDouble
This item is visible only if the Reinf item is set to True.
It is the clear cover for the specified rebar
- RebarSize
- Type: SystemString
This item is visible only if the Reinf item is set to True.
It is the size of the reinforcing bar.
- MatRebar
- Type: SystemString
The material property for the edge and corner reinforcing steel associated with the shape.
This item applies only when the MatProp item is a concrete material and the Reinf item is True.
Return Value
Type:
Int32
Returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value
Remarks
See Also