cPropFrameSDShape Interface

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
public interface cPropFrameSDShape

The cPropFrameSDShape type exposes the following members.

Methods
  NameDescription
Public methodGetAngle
Retrieves property data for an Angle shape in a section designer section
Public methodGetConcreteL
Retrieves property data for a concrete L shape in a section designer section
Public methodGetConcreteTee
Retrieves property data for a concrete tee shape in a section designer section
Public methodGetISection
Retrieves property data for an I-section shape in a section designer section
Public methodGetReinfCircle
Retrieves property data for a circular reinforcing shape in a section designer section
Public methodGetReinfCorner
Retrieves corner point reinforcing data for solid rectangle, circle and polygon shapes in a section designer property
Public methodGetReinfEdge
Retrieves edge reinforcing data for solid rectangle, circle, polygon, and rectangular reinforcing shapes in a section designer property
Public methodGetReinfLine
Retrieves property data for a line reinforcing shape in a section designer section
Public methodGetReinfRectangular
Retrieves property data for a rectangular reinforcing shape in a section designer section
Public methodGetReinfSingle
Retrieves property data for a single bar reinforcing shape in a section designer section
Public methodGetSolidCircle
Retrieves property data for a solid circle shape in a section designer section
Public methodGetSolidRect
Retrieves property data for a solid rectangular shape in a section designer section
Public methodGetTee
Retrieves property data for a Tee shape in a section designer section
Top
See Also