cPropFrameSDShapeGetReinfEdge Method |
Retrieves edge reinforcing data for solid rectangle,
circle, polygon, and rectangular reinforcing shapes in a section designer property
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetReinfEdge(
string Name,
string ShapeName,
ref int NumberItems,
ref int[] EdgeNum,
ref string[] RebarSize,
ref double[] Spacing,
ref double[] Cover
)
Function GetReinfEdge (
Name As String,
ShapeName As String,
ByRef NumberItems As Integer,
ByRef EdgeNum As Integer(),
ByRef RebarSize As String(),
ByRef Spacing As Double(),
ByRef Cover As Double()
) As Integer
int GetReinfEdge(
String^ Name,
String^ ShapeName,
int% NumberItems,
array<int>^% EdgeNum,
array<String^>^% RebarSize,
array<double>^% Spacing,
array<double>^% Cover
)
abstract GetReinfEdge :
Name : string *
ShapeName : string *
NumberItems : int byref *
EdgeNum : int[] byref *
RebarSize : string[] byref *
Spacing : float[] byref *
Cover : float[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing frame section property that is a section designer section
- ShapeName
- Type: SystemString
The name of an existing solid rectangle shape in the specified frame section property
- NumberItems
- Type: SystemInt32
The number of edges in the shape
- EdgeNum
- Type: SystemInt32
This is an array that includes the edge number in the shape
- RebarSize
- Type: SystemString
This is an array that includes None or the name of a defined rebar, indicating the rebar assignment to the considered edge
- Spacing
- Type: SystemDouble
This is an array that includes the rebar maximum center-to-center along the considered edge. [L]
- Cover
- Type: SystemDouble
This is an array that includes the rebar clear cover along the considered edge. [L]
Return Value
Type:
Int32
Returns zero if the property data is successfully retrieved; otherwise it returns a nonzero value
Remarks
See Also