cAnalysisResultsJointDrifts Method |
Reports the joint drifts
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint JointDrifts(
ref int NumberResults,
ref string[] Story,
ref string[] Label,
ref string[] Name,
ref string[] LoadCase,
ref string[] StepType,
ref double[] StepNum,
ref double[] DisplacementX,
ref double[] DisplacementY,
ref double[] DriftX,
ref double[] DriftY
)
Function JointDrifts (
ByRef NumberResults As Integer,
ByRef Story As String(),
ByRef Label As String(),
ByRef Name As String(),
ByRef LoadCase As String(),
ByRef StepType As String(),
ByRef StepNum As Double(),
ByRef DisplacementX As Double(),
ByRef DisplacementY As Double(),
ByRef DriftX As Double(),
ByRef DriftY As Double()
) As Integer
int JointDrifts(
int% NumberResults,
array<String^>^% Story,
array<String^>^% Label,
array<String^>^% Name,
array<String^>^% LoadCase,
array<String^>^% StepType,
array<double>^% StepNum,
array<double>^% DisplacementX,
array<double>^% DisplacementY,
array<double>^% DriftX,
array<double>^% DriftY
)
abstract JointDrifts :
NumberResults : int byref *
Story : string[] byref *
Label : string[] byref *
Name : string[] byref *
LoadCase : string[] byref *
StepType : string[] byref *
StepNum : float[] byref *
DisplacementX : float[] byref *
DisplacementY : float[] byref *
DriftX : float[] byref *
DriftY : float[] byref -> int
Parameters
- NumberResults
- Type: SystemInt32
The total number of results returned by the program
- Story
- Type: SystemString
This is an array of the story levels associated with each result
- Label
- Type: SystemString
This is an array of the point labels for each result
- Name
- Type: SystemString
This is an array of the unique point names for each result
- LoadCase
- Type: SystemString
This is an array of the names of the analysis case or load combination associated with each result
- StepType
- Type: SystemString
This is an array of the step types, if any, for each result
- StepNum
- Type: SystemDouble
This is an array of the step numbers, if any, for each result
- DisplacementX
- Type: SystemDouble
This is an array of the displacements in the X direction [L]
- DisplacementY
- Type: SystemDouble
This is an array of the displacements in the Y direction [L]
- DriftX
- Type: SystemDouble
This is an array of the drifts in the X direction [L]
- DriftY
- Type: SystemDouble
This is an array of the drifts in the Y direction [L]
Return Value
Type:
Int32
Returns zero if the results are successfully recovered, otherwise it returns a nonzero value
Remarks
See Also