cAnalysisResults Interface

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
public interface cAnalysisResults

The cAnalysisResults type exposes the following members.

Properties
  NameDescription
Public propertySetup
Top
Methods
  NameDescription
Public methodAreaForceShell
Reports the area forces for the specified area elements that are assigned shell section properties (not plane or asolid properties). Note that the forces reported are per unit of in-plane length.
Public methodAreaJointForceShell
Reports the area joint forces for the point elements at each corner of the specified area elements that have shell-type properties
Public methodAreaStressShell
Reports the area stresses for the specified area elements that are assigned shell section properties. Stresses are reported at each point element associated with the area element
Public methodAreaStressShellLayered
Reports the area stresses for the specified area elements that are assigned layered shell section properties
Public methodAssembledJointMass
Reports the assembled joint masses for the specified point elements
Public methodBaseReact
Reports the structure total base reactions
Public methodBaseReactWithCentroid
Public methodBucklingFactor
Public methodFrameForce
Reports the frame forces for the specified line elements
Public methodFrameJointForce
Public methodGeneralizedDispl
Public methodJointAcc
Reports the joint accelerations for the specified point elements. The accelerations reported by this function are relative accelerations.
Public methodJointAccAbs
Public methodJointDispl
Public methodJointDisplAbs
Public methodJointDrifts
Reports the joint drifts
Public methodJointReact
Reports the joint reactions for the specified point elements. The reactions reported are from restraints, springs and grounded (one-joint) links.
Public methodJointVel
Public methodJointVelAbs
Public methodLinkDeformation
Public methodLinkForce
Public methodLinkJointForce
Public methodModalLoadParticipationRatios
Public methodModalParticipatingMassRatios
Public methodModalParticipationFactors
Public methodModalPeriod
Public methodModeShape
Public methodPanelZoneDeformation
Public methodPanelZoneForce
Public methodPierForce
Retrieves pier forces for any defined pier objects in the model
Public methodSectionCutAnalysis
Public methodSectionCutDesign
Public methodSpandrelForce
Retrieves spandrel forces for any defined spandrel objects in the model
Public methodStoryDrifts
Reports the story drifts
Top
See Also