cGridSysGetTransformationMatrix Method

Retrieves the grid system transformation matrix.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetTransformationMatrix(
	string Name,
	ref double[] Value
)

Parameters

Name
Type: SystemString
The name of an existing grid system.
Value
Type: SystemDouble
Value is an array of nine direction cosines that define the transformation matrix from the specified grid system to the global grid system.

Return Value

Type: Int32
Returns zero if the grid system transformation matrix is successfully returned, otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
   ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'define new grid system
   ret = SapModel.GridSys.SetGridSys("GridSysA", 1000, 1000, 0, 0, 0, 0)

'get grid system transformation matrix
   ReDim Value(8)
   ret = SapModel.GridSys.GetTransformationMatrix("GridSysA", Value)

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also