cPropFrameGetTube Method

Retrieves frame section property data for a tube-type frame section.

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int GetTube(
	string Name,
	ref string FileName,
	ref string MatProp,
	ref double T3,
	ref double T2,
	ref double Tf,
	ref double Tw,
	ref int Color,
	ref string Notes,
	ref string GUID
)

Parameters

Name
Type: SystemString
The name of an existing frame section property.
FileName
Type: SystemString
If the section property was imported from a property file, this is the name of that file. If the section property was not imported, this item is blank.
MatProp
Type: SystemString
The name of the material property for the section.
T3
Type: SystemDouble
T2
Type: SystemDouble
Tf
Type: SystemDouble
Tw
Type: SystemDouble
Color
Type: SystemInt32
Notes
Type: SystemString
GUID
Type: SystemString
The GUID (global unique identifier), if any, assigned to the section.

Return Value

Type: Int32
Returns zero if the section property data is successfully retrieved; otherwise it returns a nonzero value.
Remarks
Examples
VB
Public Sub Example()
       Dim SapModel As cSapModel
       Dim EtabsObject As cOAPI
       Dim ret As Integer = -1

   'create ETABS object
       EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

   'start ETABS application
       ret = EtabsObject.ApplicationStart()

   'create SapModel object
       SapModel = EtabsObject.SapModel

   'initialize model
       ret = SapModel.InitializeNewModel()

   'create steel deck template model
       ret = SapModel.File.NewSteelDeck(4,12,12,4,4,24,24)

   'set new frame section property
       ret = SapModel.PropFrame.SetTube("TUBE1", "A992Fy50", 8, 6, 0.5, 0.5)

   'close ETABS
       EtabsObject.ApplicationExit(False)

   'clean up variables
       SapModel = Nothing
       EtabsObject = Nothing
   End Sub
See Also