cPropFrame Interface

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
public interface cPropFrame

The cPropFrame type exposes the following members.

Properties
  NameDescription
Public propertySDShape
Gives access to OAPI calls related to Section Designer sections.
Top
Methods
  NameDescription
Public methodChangeName
Changes the name of an existing frame section property.
Public methodCount
Retrieves the total number of defined frame section properties in the model.
Public methodDelete
Deletes a specified frame section property.
Public methodGetAllFrameProperties
Retrieves select data for all frame properties in the model
Public methodGetAngle
Retrieves frame section property data for an angle-type frame section.
Public methodGetAutoSelectSteel
Retrieves frame section property data for a steel auto select lists.
Public methodGetChannel
Retrieves frame section property data for an channel-type frame section.
Public methodGetCircle
Retrieves frame section property data for a circular frame section.
Public methodGetConcreteL
Retrieves frame section property data for a concrete L frame section.
Public methodGetConcreteTee
Retrieves frame section property data for a concrete tee frame section.
Public methodGetCoverPlatedI
retrieves frame section property data for a cover plated I-type frame section.
Public methodGetDblAngle
Retrieves frame section property data for a double angle-type frame section.
Public methodGetDblChannel
Retrieves frame section property data for a double channel-type frame section.
Public methodGetGeneral
Retrieves frame section property data for a general frame section
Public methodGetISection
Retrieves frame section property data for an I-type frame section.
Public methodGetModifiers
Retrieves the modifier assignments for a frame section property. The default value for all modifiers is one.
Public methodGetNameInPropFile
Retrieves the names of the section property file from which an imported frame section originated, and it also retrieves the section name used in the property file.
Public methodGetNameList
Retrieves the names of all defined frame section properties of the specified type.
Public methodGetNonPrismatic
Assigns data to a nonprismatic frame section property.
Public methodGetPipe
Retrieves frame section property data for a pipe-type frame section.
Public methodGetPlate
Retrieves frame section property data for a plate frame section.
Public methodGetPropFileNameList
Retrieves the names of all defined frame section properties of a specified type in a specified frame section property file.
Public methodGetRebarBeam
Retrieves beam rebar data for frame sections.
Public methodGetRebarColumn
Retrieves column rebar data for frame sections.
Public methodGetRectangle
Retrieves frame section property data for a rectangular frame section.
Public methodGetRod
Retrieves frame section property data for a rod frame section.
Public methodGetSDSection
Retrieves section property data for a section designer section
Public methodGetSectProps
Public methodGetSteelAngle
Retrieves frame section property data for a steel angle frame section.
Public methodGetSteelTee
Retrieves frame section property data for a steel tee frame section.
Public methodGetTee
Retrieves frame section property data for a tee-type frame section.
Public methodGetTube
Retrieves frame section property data for a tube-type frame section.
Public methodGetTypeOAPI
Retrieves the property type for the specified frame section property.
Public methodGetTypeRebar
Retrieves the rebar design type for the specified frame section property
Public methodImportProp
Imports a frame section property from a property file.
Public methodSetAngle
Initializes an angle-type frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetAutoSelectSteel
Assigns frame section properties to an auto select list. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetChannel
Initializes an channel-type frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetCircle
initializes a solid circular frame section property.If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetConcreteL
Initializes a concrete L frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetConcreteTee
Initializes a concrete tee frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetCoverPlatedI
Initializes a cover plated I-type frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetDblAngle
Initializes a double angle-type frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetDblChannel
Initializes a double channel-type frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetGeneral
Initializes a general frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetISection
Initializes an I-type frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetModifiers
Assigns property modifiers to a frame section property. The default value for all modifiers is one.
Public methodSetNonPrismatic
Assigns data to a nonprismatic frame section property.
Public methodSetPipe
Initializes a pipe-type frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetPlate
Initializes a solid plate frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetRebarBeam
Assigns beam rebar data to frame sections.
Public methodSetRebarColumn
Assigns column rebar data to frame sections.
Public methodSetRectangle
Initializes a solid rectangular frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetRod
initializes a solid rod frame section property.If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetSDSection
Public methodSetSteelAngle
Initializes a steel angle frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetSteelTee
Initializes a steel tee frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetTee
Initializes a tee-type frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Public methodSetTube
Initializes a tube-type frame section property. If this function is called for an existing frame section property, all items for the section are reset to their default value.
Top
See Also