cPointObjGetConnectivity Method |
Retrieves a list of objects connected to a specified point object
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetConnectivity(
string Name,
ref int NumberItems,
ref int[] ObjectType,
ref string[] ObjectName,
ref int[] PointNumber
)
Function GetConnectivity (
Name As String,
ByRef NumberItems As Integer,
ByRef ObjectType As Integer(),
ByRef ObjectName As String(),
ByRef PointNumber As Integer()
) As Integer
int GetConnectivity(
String^ Name,
int% NumberItems,
array<int>^% ObjectType,
array<String^>^% ObjectName,
array<int>^% PointNumber
)
abstract GetConnectivity :
Name : string *
NumberItems : int byref *
ObjectType : int[] byref *
ObjectName : string[] byref *
PointNumber : int[] byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing point object
- NumberItems
- Type: SystemInt32
This is the total number of objects connected to the specified point object
- ObjectType
- Type: SystemInt32
This is an array that includes the object type of each object connected to the specified point object.
2 | Frame object |
3 | Cable object |
4 | Tendon object |
5 | Area object |
6 | Solid object |
7 | Link object |
- ObjectName
- Type: SystemString
This is an array that includes the object name of each object connected to the specified point object
- PointNumber
- Type: SystemInt32
This is an array that includes the point number within the considered object that corresponds to the specified point object
Return Value
Type:
Int32
Returns zero if the list is successfully filled; otherwise it returns nonzero
Remarks
See Also