cPointObj Interface

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
public interface cPointObj

The cPointObj type exposes the following members.

Methods
  NameDescription
Public methodAddCartesian
Adds a point object to a model. The added point object will be tagged as a Special Point except if it was merged with another point object. Special points are allowed to exist in the model with no objects connected to them.
Public methodChangeName
Public methodCount
Public methodCountLoadDispl
Public methodCountLoadForce
Public methodCountPanelZone
Public methodCountRestraint
Public methodCountSpring
Public methodDeleteLoadDispl
Deletes all ground displacement load assignments, for the specified load pattern, from the specified point object(s).
Public methodDeleteLoadForce
Deletes all point force load assignments, for the specified load pattern, from the specified point object(s).
Public methodDeleteMass
Public methodDeletePanelZone
Public methodDeleteRestraint
Deletes all restraint assignments from the specified point object(s).
Public methodDeleteSpecialPoint
Deletes special point objects that have no other objects connected to them.
Public methodDeleteSpring
Deletes all point spring assignments from the specified point object(s).
Public methodGetAllPoints
Retrieves selected data for all point objects in the model
Public methodGetCommonTo
Public methodGetConnectivity
Retrieves a list of objects connected to a specified point object
Public methodGetCoordCartesian
Retrieves the x, y and z coordinates of the specified point object in the Present Units.
Public methodGetCoordCylindrical
Public methodGetCoordSpherical
Public methodGetDiaphragm
Retrieves the diaphragm for a specified point object
Public methodGetElm
Public methodGetGUID
Retrieves the GUID for specified point object.
Public methodGetLabelFromName
Retrieves the label and story for a unique point object name
Public methodGetLabelNameList
Retrieves the names and labels of all defined point objects.
Public methodGetLoadDispl
Retrieves the ground displacement load assignments to point objects.
Public methodGetLoadForce
Retrieves the joint force load assignments to point objects.
Public methodGetLocalAxes
Retrieves the local axis angles for a point object.
Public methodGetMass
Public methodGetNameFromLabel
Retrieves the unique name of a point object, given the label and story level
Public methodGetNameList
Retrieves the names of all defined point objects.
Public methodGetNameListOnStory
Retrieves the names of the defined point objects on a given story.
Public methodGetPanelZone
Public methodGetRestraint
Retrieves the restraint assignments for a point object. The restraint assignments are always returned in the point local coordinate system.
Public methodGetSelected
Public methodGetSpecialPoint
Public methodGetSpring
Retrieves uncoupled spring stiffness assignments for a point object, that is, it retrieves the diagonal terms in the 6x6 spring matrix for the point object.
Public methodGetSpringCoupled
Public methodGetTransformationMatrix
Public methodIsSpringCoupled
Public methodSetDiaphragm
Assigns a diaphragm to a point object
Public methodSetGroupAssign
Adds or removes point objects from a specified group.
Public methodSetGUID
Sets the GUID for specified point object. If the GUID is passed in as a blank string, the program automatically creates a GUID for the object.
Public methodSetLoadDispl
Makes ground displacement load assignments to point objects.
Public methodSetLoadForce
Makes point force load assignments to point objects.
Public methodSetMass
Public methodSetMassByVolume
Public methodSetMassByWeight
Public methodSetPanelZone
Public methodSetRestraint
Assigns the restraint assignments for a point object. The restraint assignments are always set in the point local coordinate system.
Public methodSetSelected
Sets the selected status for a point object.
Public methodSetSpecialPoint
Sets the special point status for a point object.
Public methodSetSpring
Assigns coupled springs to a point object.
Public methodSetSpringCoupled
Top
See Also