cPropFrameGetSDSection Method |
Retrieves section property data for a section designer section
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetSDSection(
string Name,
ref string MatProp,
ref int NumberItems,
ref string[] ShapeName,
ref int[] MyType,
ref int DesignType,
ref int Color,
ref string Notes,
ref string GUID
)
Function GetSDSection (
Name As String,
ByRef MatProp As String,
ByRef NumberItems As Integer,
ByRef ShapeName As String(),
ByRef MyType As Integer(),
ByRef DesignType As Integer,
ByRef Color As Integer,
ByRef Notes As String,
ByRef GUID As String
) As Integer
int GetSDSection(
String^ Name,
String^% MatProp,
int% NumberItems,
array<String^>^% ShapeName,
array<int>^% MyType,
int% DesignType,
int% Color,
String^% Notes,
String^% GUID
)
abstract GetSDSection :
Name : string *
MatProp : string byref *
NumberItems : int byref *
ShapeName : string[] byref *
MyType : int[] byref *
DesignType : int byref *
Color : int byref *
Notes : string byref *
GUID : string byref -> int
Parameters
- Name
- Type: SystemString
The name of an existing section designer property
- MatProp
- Type: SystemString
The name of the base material property for the section
- NumberItems
- Type: SystemInt32
The number of shapes defined in the section designer section
- ShapeName
- Type: SystemString
This is an array that includes the name of each shape in the section designer section
- MyType
- Type: SystemInt32
This is an array that includes the type of each shape in the section designer section
1 | I-Section |
2 | Channel |
3 | Tee |
4 | Angle |
5 | Double Angle |
6 | Box |
7 | Pipe |
8 | Plate |
61 | Concrete Tee |
62 | Concrete L |
63 | Concrete Box |
64 | Concrete Pipe |
65 | Concrete Cross |
101 | Solid Rectangle |
102 | Solid Circle |
103 | Solid Segment |
104 | Solid Sector |
201 | Polygon |
301 | Reinforcing Single |
302 | Reinforcing Line |
303 | Reinforcing Rectangle |
304 | Reinforcing Circle |
401 | Reference Line |
402 | Reference Circle |
- DesignType
- Type: SystemInt32
This is 0, 1, 2 or 3, indicating the design option for the section
0 | No design |
1 | Design as general steel section |
2 | Design as a concrete column; check the reinforcing |
3 | Design as a concrete column; design the reinforcing |
- Color
- Type: SystemInt32
The display color assigned to the section
- Notes
- Type: SystemString
The notes, if any, assigned to the section
- GUID
- Type: SystemString
The GUID (global unique identifier), if any, assigned to the section
Return Value
Type:
Int32
Returns zero if the section property data is successfully retrieved; otherwise it returns a nonzero value
Remarks
See Also