cFrameObjDeleteLoadPoint Method |
Namespace: ETABS2016
int DeleteLoadPoint( string Name, string LoadPat, eItemType ItemType = eItemType.Objects )
If this item is Objects, the load assignments are deleted for the frame object specified by the Name item.
If this item is Group, the load assignments are deleted for all frame objects in the group specified by the Name item.
If this item is SelectedObjects, the load assignments are deleted for all selected frame objects, and the Name item is ignored.
Public Sub Example() Dim SapModel As cSapModel Dim EtabsObject As cOAPI Dim ret As Integer = -1 'create ETABS object EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject") 'start ETABS application ret = EtabsObject.ApplicationStart() 'create SapModel object SapModel = EtabsObject.SapModel 'initialize model ret = SapModel.InitializeNewModel() 'create steel deck template model ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24) 'assign frame point loads ret = SapModel.FrameObj.SetLoadPoint("14", "DEAD", 1, 10, .5, 20) ret = SapModel.FrameObj.SetLoadPoint("15", "DEAD", 1, 10, .5, 20) 'delete frame point load ret = SapModel.FrameObj.DeleteLoadPoint("14", "DEAD") 'close ETABS EtabsObject.ApplicationExit(False) 'clean up variables SapModel = Nothing EtabsObject = Nothing End Sub