cFrameObj Interface

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
public interface cFrameObj

The cFrameObj type exposes the following members.

Methods
  NameDescription
Public methodAddByCoord
Adds a new frame object whose end points are at the specified coordinates.
Public methodAddByPoint
Adds a new frame object whose end points are specified by name.
Public methodChangeName
Public methodCount
Public methodDelete
Deletes frame objects.
Public methodDeleteLateralBracing
Public methodDeleteLoadDistributed
Deletes the distributed load assignments to the specified frame objects for the specified load pattern.
Public methodDeleteLoadPoint
Deletes the point load assignments to the specified frame objects for the specified load pattern.
Public methodDeleteLoadTemperature
Public methodDeleteMass
Public methodDeleteModifiers
Public methodDeleteSpring
Public methodGetAllFrames
Retrieves select data for all frame objects in the model
Public methodGetColumnSpliceOverwrite
Retrieves the frame object column splice overwrite assignment.
Public methodGetDesignOrientation
Retrieves the design orientation for a given frame object
Public methodGetDesignProcedure
Retrieves the design procedure for a frame object
Public methodGetElm
Public methodGetEndLengthOffset
Retrieves the frame object end offsets along the 1-axis of the object.
Public methodGetGUID
Retrieves the GUID for the specified frame object.
Public methodGetHingeAssigns
Public methodGetInsertionPoint
Retrieves frame object insertion point assignments. The assignments include the cardinal point and end joint offsets.
Public methodGetLabelFromName
Retrieves the label and story for a unique frame object name
Public methodGetLabelNameList
Retrieves the names and labels of all defined frame objects.
Public methodGetLateralBracing
Public methodGetLoadDistributed
Retrieves the distributed load assignments to frame objects.
Public methodGetLoadPoint
Retrieves the point load assignments to frame objects.
Public methodGetLoadTemperature
Retrieves the temperature load assignments to frame objects.
Public methodGetLocalAxes
Retrieves the frame local axis angle assignment for frame objects.
Public methodGetMass
Public methodGetMaterialOverwrite
Public methodGetModifiers
Retrieves the frame modifier assignment for frame objects. The default value for all modifiers is one.
Public methodGetNameFromLabel
Retrieves the unique name of a frame object, given the label and story level
Public methodGetNameList
Retrieves the names of all defined frame objects.
Public methodGetNameListOnStory
Retrieves the names of the defined frame objects on a given story.
Public methodGetOutputStations
Retrieves frame object output station data
Public methodGetPier
Retrieves the pier label assignments of a frame object
Public methodGetPoints
Retrieves the names of the point objects at each end of a specified frame object.
Public methodGetReleases
Public methodGetSection
Retrieves the frame section property assigned to a frame object.
Public methodGetSectionNonPrismatic
Public methodGetSelected
Public methodGetSpandrel
Retrieves the Spandrel label assignments of a frame object
Public methodGetSupports
Retrieves support data for a given frame beam object
Public methodGetTCLimits
Public methodGetTransformationMatrix
Public methodSetColumnSpliceOverwrite
Sets the frame object column splice overwrite assignment.
Public methodSetDesignProcedure
Sets the design procedure for frame objects.
Public methodSetEndLengthOffset
Assigns frame object end offsets along the 1-axis of the object.
Public methodSetGroupAssign
Adds or removes frame objects from a specified group.
Public methodSetGUID
Sets the GUID for the specified frame object. If the GUID is passed in as a blank string, the program automatically creates a GUID for the object.
Public methodSetInsertionPoint
Assigns frame object insertion point data. The assignments include the cardinal point and end joint offsets.
Public methodSetLateralBracing
Public methodSetLoadDistributed
Assigns distributed loads to frame objects.
Public methodSetLoadPoint
Assigns point loads to frame objects.
Public methodSetLoadTemperature
Public methodSetLocalAxes
Assigns a local axis angle to frame objects.
Public methodSetMass
Public methodSetMaterialOverwrite
Public methodSetModifiers
Sets the frame modifier assignment for frame objects. The default value for all modifiers is one
Public methodSetOutputStations
Assigns frame object output station data.
Public methodSetPier
Sets the pier label assignment of one or more frame objects
Public methodSetReleases
Makes end release and partial fixity assignments to frame objects.
Public methodSetSection
Assigns a frame section property to a frame object.
Public methodSetSelected
Sets the selected status for a frame object.
Public methodSetSpandrel
Sets the Spandrel label assignment of one or more frame objects
Public methodSetTCLimits
Makes tension/compression force limit assignments to frame objects.
Top
See Also