cFrameObjSetModifiers Method

Sets the frame modifier assignment for frame objects. The default value for all modifiers is one

Namespace:  ETABS2016
Assembly:  ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
int SetModifiers(
	string Name,
	ref double[] Value,
	eItemType ItemType = eItemType.Objects
)

Parameters

Name
Type: SystemString
The name of an existing frame object or group, depending on the value of the ItemType item.
Value
Type: SystemDouble
This is an array of eight unitless modifiers:
ValueModifier
Value(0)Cross sectional area modifier
Value(1)Shear area in local 2 direction modifier
Value(2)Shear area in local 3 direction modifier
Value(3)Torsional constant modifier
Value(4)Moment of inertia about local 2 axis modifier
Value(5)Moment of inertia about local 3 axis modifier
Value(6)Mass modifier
Value(7)Weight modifier
ItemType (Optional)
Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
  • Object = 0
  • Group = 1
  • SelectedObjects = 2

If this item is Objects, the assignment is made to the frame object specified by the Name item.

If this item is Group, the assignment is made to all frame objects in the group specified by the Name item.

If this item is SelectedObjects, the assignment is made to all selected frame objects and the Name item is ignored.

Return Value

Type: Int32
Returns zero if the modifier assignments are successfully assigned, otherwise it returns a nonzero value
Remarks
Examples
VB
Public Sub Example()
   Dim SapModel As cSapModel
   Dim EtabsObject As cOAPI
   Dim ret As Integer = -1
   Dim Value() As Double

'create ETABS object
   EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")

'start ETABS application
  ret = EtabsObject.ApplicationStart()

'create SapModel object
   SapModel = EtabsObject.SapModel

'initialize model
   ret = SapModel.InitializeNewModel()

'create steel deck template model
   ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)

'assign modifiers
    ReDim Value(7)
    For i = 0 To 7
        Value(i) = 1
    Next i
    Value(5) = 100
    ret = SapModel.FrameObj.SetModifiers("3", Value, eItemType.Objects)

'get modifiers
    Dim myValue As Double()
    ret = SapModel.FrameObj.GetModifiers("3", myValue)

'close ETABS
   EtabsObject.ApplicationExit(False)

'clean up variables
   SapModel = Nothing
   EtabsObject = Nothing

End Sub
See Also