cFrameObjGetLoadTemperature Method |
Retrieves the temperature load assignments to frame objects.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint GetLoadTemperature(
string Name,
ref int NumberItems,
ref string[] FrameName,
ref string[] LoadPat,
ref int[] MyType,
ref double[] Val,
ref string[] PatternName,
eItemType ItemType = eItemType.Objects
)
Function GetLoadTemperature (
Name As String,
ByRef NumberItems As Integer,
ByRef FrameName As String(),
ByRef LoadPat As String(),
ByRef MyType As Integer(),
ByRef Val As Double(),
ByRef PatternName As String(),
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int GetLoadTemperature(
String^ Name,
int% NumberItems,
array<String^>^% FrameName,
array<String^>^% LoadPat,
array<int>^% MyType,
array<double>^% Val,
array<String^>^% PatternName,
eItemType ItemType = eItemType::Objects
)
abstract GetLoadTemperature :
Name : string *
NumberItems : int byref *
FrameName : string[] byref *
LoadPat : string[] byref *
MyType : int[] byref *
Val : float[] byref *
PatternName : string[] byref *
?ItemType : eItemType
(* Defaults:
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing frame object or group, depending on the
value of the ItemType item.
- NumberItems
- Type: SystemInt32
The total number of temperature loads retrieved for the specified frame objects.
- FrameName
- Type: SystemString
This is an array that includes the name of the frame object associated
with each temperature load.
- LoadPat
- Type: SystemString
This is an array that includes the name of the load pattern associated
with each temperature load.
- MyType
- Type: SystemInt32
This is an array that includes 1, 2 or 3, indicating the type of temperature load.
- Temperature
- Temperature gradient along local 2 axis
- Temperature gradient along local 3 axis
- Val
- Type: SystemDouble
- PatternName
- Type: SystemString
This is an array that includes the joint pattern name, if any,
used to specify the temperature load.
- ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignments are retrieved for the frame object
specified by the Name item.
If this item is Group, the assignments are retrieved for all frame objects
in the group specified by the Name item.
If this item is SelectedObjects, the assignments are retrieved for all
selected frame objects and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the load assignments are successfully retrieved,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
Dim NumberItems As Integer
Dim FrameName() As String
Dim LoadPat() As String
Dim MyType() As Integer
Dim Val() As Double
Dim PatternName() As String
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.SetLoadTemperature("All", "DEAD", 1, 50, , , eItemType.Group)
ret = SapModel.FrameObj.GetLoadTemperature("ALL", NumberItems, FrameName, LoadPat, MyType, Val, PatternName, eItemType.Group)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also