cFrameObjSetOutputStations Method |
Assigns frame object output station data.
Namespace:
ETABS2016
Assembly:
ETABS2016 (in ETABS2016.dll) Version: 16.0.0.0 (16.0.0.0)
Syntaxint SetOutputStations(
string Name,
int MyType,
double MaxSegSize,
int MinSections,
bool NoOutPutAndDesignAtElementEnds = false,
bool NoOutPutAndDesignAtPointLoads = false,
eItemType ItemType = eItemType.Objects
)
Function SetOutputStations (
Name As String,
MyType As Integer,
MaxSegSize As Double,
MinSections As Integer,
Optional NoOutPutAndDesignAtElementEnds As Boolean = false,
Optional NoOutPutAndDesignAtPointLoads As Boolean = false,
Optional ItemType As eItemType = eItemType.Objects
) As Integer
int SetOutputStations(
String^ Name,
int MyType,
double MaxSegSize,
int MinSections,
bool NoOutPutAndDesignAtElementEnds = false,
bool NoOutPutAndDesignAtPointLoads = false,
eItemType ItemType = eItemType::Objects
)
abstract SetOutputStations :
Name : string *
MyType : int *
MaxSegSize : float *
MinSections : int *
?NoOutPutAndDesignAtElementEnds : bool *
?NoOutPutAndDesignAtPointLoads : bool *
?ItemType : eItemType
(* Defaults:
let _NoOutPutAndDesignAtElementEnds = defaultArg NoOutPutAndDesignAtElementEnds false
let _NoOutPutAndDesignAtPointLoads = defaultArg NoOutPutAndDesignAtPointLoads false
let _ItemType = defaultArg ItemType eItemType.Objects
*)
-> int
Parameters
- Name
- Type: SystemString
The name of an existing frame object or group, depending on the
value of the ItemType item.
- MyType
- Type: SystemInt32
This is 1 or 2, indicating how the output stations are specified.
- maximum segment size, that is, maximum station spacing
- minimum number of stations
- MaxSegSize
- Type: SystemDouble
The maximum segment size, that is, the maximum station spacing.
This item applies only when MyType = 1. [L]
- MinSections
- Type: SystemInt32
The minimum number of stations. This item applies only when
MyType = 2.
- NoOutPutAndDesignAtElementEnds (Optional)
- Type: SystemBoolean
If this item is True, no additional output stations are added
at the ends of line elements when the frame object is internally meshed.
In ETABS, this item will always be False - NoOutPutAndDesignAtPointLoads (Optional)
- Type: SystemBoolean
If this item is True, no additional output stations are added
at point load locations. In ETABS, this item will always be False - ItemType (Optional)
- Type: ETABS2016eItemType
This is one of the following items in the eItemType enumeration:
- Object = 0
- Group = 1
- SelectedObjects = 2
If this item is Objects, the assignment is made to the frame object
specified by the Name item.
If this item is Group, the assignment is made to all frame objects
in the group specified by the Name item.
If this item is SelectedObjects, the assignment is made to all
selected frame objects and the Name item is ignored.
Return Value
Type:
Int32
Returns zero if the data is successfully assigned,
otherwise it returns a nonzero value.
Remarks
ExamplesPublic Sub Example()
Dim SapModel As cSapModel
Dim EtabsObject As cOAPI
Dim ret As Integer = -1
EtabsObject = CreateObject("CSI.ETABS.API.ETABSObject")
ret = EtabsObject.ApplicationStart()
SapModel = EtabsObject.SapModel
ret = SapModel.InitializeNewModel()
ret = SapModel.File.NewSteelDeck(4, 12, 12, 4, 4, 24, 24)
ret = SapModel.FrameObj.SetOutputStations("15", 1, 18, 0)
EtabsObject.ApplicationExit(False)
SapModel = Nothing
EtabsObject = Nothing
End Sub
See Also